Skip to:
Content

BuddyPress.org

Opened 12 years ago

Closed 12 years ago

Last modified 9 years ago

#4290 closed defect (bug) (no action required)

Plugin could not be activated because it triggered a fatal error

Reported by: qrahaman's profile qrahaman Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.6
Component: Core Keywords: reporter-feedback
Cc:

Description

I had to troubleshoot because the Widget sidebar in Appearance>Widgets was missing. Isolated this to the Buddystream 2.13 plugin. However, I deactivated all of the plugins to identify it.

I then tried to reactivate BuddyPress and got the following (no other plugins are active):

Notice: Constant BP_DEFAULT_COMPONENT already defined in /home/thedancersportfolio/websites/thedancersportfolio.com/htdocs/wp-content/plugins/bp-custom.php on line 16 Notice: Constant BP_ACTIVITY_SLUG already defined in /home/thedancersportfolio/websites/thedancersportfolio.com/htdocs/wp-content/plugins/bp-custom.php on line 20 Warning: require(/home/thedancersportfolio/websites/thedancersportfolio.com/htdocs/wp-content/plugins/buddypressbp-core/bp-core-actions.php): failed to open stream: No such file or directory in /home/thedancersportfolio/websites/thedancersportfolio.com/htdocs/wp-content/plugins/buddypress/bp-loader.php on line 409 Fatal error: require(): Failed opening required '/home/thedancersportfolio/websites/thedancersportfolio.com/htdocs/wp-content/plugins/buddypressbp-core/bp-core-actions.php' (include_path='.:/usr/share/php:/usr/share/pear') in /home/thedancersportfolio/websites/thedancersportfolio.com/htdocs/wp-content/plugins/buddypress/bp-loader.php on line 409

Wordpress 3.4

Change History (5)

#1 @DJPaul
12 years ago

What's in your bp-custom.php -- can you show us on pastebin.com please?

#2 @boonebgorges
12 years ago

Yes, it looks like you have defined BP_PLUGIN_DIR in your bp-custom.php or wp-config.php, and left out the trailing slash.

Is this a regression? In any case, we should probably add a trailingslashit() to bp-loader.php:328, where $this->plugin_dir is defined. Objections?

#3 @DJPaul
12 years ago

  • Keywords reporter-feedback added

#4 @DJPaul
12 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Closing ticket as no response from reporter and problem is most likely in a custom bp-custom.php.

#5 @johnjamesjacoby
9 years ago

  • Version changed from 1.6-beta to 1.6
Note: See TracTickets for help on using tickets.