Skip to:
Content

BuddyPress.org

Opened 11 years ago

Closed 11 years ago

#41 closed defect (bug) (fixed)

Multiple Friend Requests from Same Person

Reported by: sollaires Owned by:
Milestone: Priority: minor
Severity: Version:
Component: Keywords:
Cc:

Description

I'm not entirely sure how to reproduce this, but something caused a Firebug error to pop up when I was using the "Add Friend" button, possibly related to Firebug console usage.

Anyway, JS error caused the Add Friend button to not be greyed out and each request sent using the button showed up as a dupe friend request. As soon as one of them was confirmed, they all went away.

very minor, just thought I'd document it.

Change History (2)

#1 @sollaires
11 years ago

Addition: the same user does show up as a friend multiple times on the friend screen when this happens. Should check for duplicate friendship connection when requesting an "Add Friend" and when confirming a friend request.

#2 @apeatling
11 years ago

  • Resolution set to fixed
  • Status changed from new to closed

This has been fixed by removing the link and adding a "working..." text to replace it. This is live on testdrivewpmu.com now.

Note: See TracTickets for help on using tickets.