Skip to:
Content

Opened 2 years ago

Closed 2 years ago

#4024 closed defect (bug) (invalid)

BuddyBar links are being directed to the incorrect blog

Reported by: protesta Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.5.4
Component: Toolbar/BuddyBar Keywords:
Cc: arthurpellerano@…, protesta

Description

When I followed the directions, every blog but #1 worked in directing the buddybar My Account navigation item and submenu to the designated blog id. However when attempting to use #1 the original problem continues to persist.

Original problem
When on a ny site other than the primary blog, the visit random, My Account and sub nav menu links all resolve to the current blog. As the associated pages are on the primary blog, 301 redirect resolves to the main page.

PLEASE ADVISE. This is a very VERY important issue.

Change History (5)

comment:1 boonebgorges2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Severity changed from blocker to normal
  • Status changed from new to closed

What was your problem opening a discussion thread at buddypress.org? Try this link http://buddypress.org/community/groups/how-to-and-troubleshooting/forum/ - be sure to be logged in, and click the New Topic link in the subnavigation.

I'm eager to see your problem resolved (which I am assuming is a duplicate of your #4021), but this is not the place to have the discussion - moreover, the people who are most knowledgeable about support are not going to see your ticket here, as they spend their time on the support forums. Please follow up there, and reopen this ticket if you discover that your issue is caused by a reproducible bug in BuddyPress itself.

comment:2 protesta2 years ago

  • Cc protesta added
  • Resolution invalid deleted
  • Severity changed from normal to blocker
  • Status changed from closed to reopened

This is a bug. None of the codex fixes to include using bp-custom.php work.
the code says what it should and displays as it should.
Still every time someone clicks on any of the my account links in the buddybar, they are taken to the page on their own site which does not have the social network.

comment:3 boonebgorges2 years ago

  • Severity changed from blocker to normal
  • Summary changed from Cannot start discussion string on buddypress.org & need assistance! BP_ROOT_BLOG to BuddyBar links are being directed to the incorrect blog

protesta - I know that this is an important issue for your site, but it is not a blocker for the software. That severity level is reserved for issues like security issues, or issues that will not allow the software to be installed, etc.

At the moment, I am unable to reproduce your issue. Can you please provide more details on your setup, and exactly what the problem is?

You say you "followed the directions". What directions? What is your setup? What is your root blog id? Can you give examples using specific URLs? (You can change to example.com if you want to be private about your URL, but at least give information like "My root blog is example.com, and on subdirectory sites like example.com/site1/...."

Please also provide info on your version of WordPress and BuddyPress, as well as any BP-specific plugins you may be running.

comment:4 boonebgorges2 years ago

Also, please let us know about any customizations you have done in bp-custom.php or wp-config.php. In particular, I have a suspicion that you have enabled BP_ENABLE_MULTIBLOG. Please provide as much information you can about your installation so that we can help determine whether this is actually a bug.

comment:5 boonebgorges2 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

I've had yet another look, and I still can't manage to reproduce this, unless I set BP_ENABLE_MULTIBLOG. protesta, if you can provide more details on how to reproduce your error - and you can ensure that you're not using BP_ENABLE_MULTIBLOG! - please reopen this ticket with those details. Thanks!

Note: See TracTickets for help on using tickets.