Skip to:
Content

BuddyPress.org

Opened 12 years ago

Closed 12 years ago

#3987 closed defect (bug) (worksforme)

Redirect Loop When Users Accesses a Private Group

Reported by: cspowers's profile cspowers Owned by:
Milestone: Priority: normal
Severity: minor Version: 1.5.3
Component: Groups Keywords:
Cc:

Description

Howdy,

I am running a sanbox install of WP and BP, both latest versions. I’m using the Suffusion theme and the minima skin. I ran into a situation where I get an infinite redirect loop.

In my sandbox I have a user “charile” and a public group “X”. Charlie joined the public group and was in it for a while. Then I changed group X to be a private group. I had charlie leave the group and verified that no group X activity appears in his streams. So far so good.

Now Charlie goes to the group directory at /groups. He sees group X in the list because it is a private group. He sees the “request to join” button. But Charlie does not click it. The group name X is a hyper link. For people who are in the group, the link will take them to the group’s home page. But when Charlie clicks the link, the browser hangs for a while and then gives an error message about multiple redirects.

If a site visitor (not registered or logged in) goes the the /groups page and clicks the name of group X, it redirects him back to the home page. But when Charlie logs in and clicks it, he gets the infinite redirect problem.

Not sure if this as anything to do with the fact that Charlie used to be a member of the group but left. Or if maybe there’s something wrong with the suffusion buddy pack. Also I have several plugins installed that add to the groups (BP Documents, U BuddyPress Editor, Events Manager, Photo Album, etc.)

I regenerated the BP files using the suffusion buddypack plugin but that did not seem to help. I'm using suffusion via a child theme and have not made any changes to any theme files or BP files.

I see the behavior both on the latest version of firfox and latest version of chrome.

This is not a huge problem. The browser eventually shows an error message and user can go back to the home page of the site or whatever. But I figured I'd report it anyway, just fyi.

Change History (1)

#1 @johnjamesjacoby
12 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Thanks for the report. I'm unable to reproduce this behavior on the latest development version of BuddyPress. That means either we inadvertently fixed it for the next release, or something on your end is causing it.

I'm going to mark this ticket as resolved 'worksforme.' Feel free to reopen it if new information comes up, or you're able to pin-point an exact fix.

Note: See TracTickets for help on using tickets.