Skip to:
Content

BuddyPress.org

Opened 10 years ago

Closed 10 years ago

#3894 closed enhancement (wontfix)

Profile tab cannot be easily disabled

Reported by: seravifer Owned by: -
Milestone: Priority: normal
Severity: normal Version: 1.5.2
Component: Extended Profile Keywords:
Cc: -, seravifer@…

Description

What happens is that when you activate "Customize your community with fully editable profile fields that allow users to describe" and decides to turn it off, the tab is still running "public".

Sorry for the misspelling, I'm Spanish

Example: http://www.familiapixel.com/perfil/seravifer/

Change History (8)

#1 @seravifer
10 years ago

  • Cc seravifer@… added

#2 @boonebgorges
10 years ago

  • Component changed from Core to Members
  • Keywords reporter-feedback removed
  • Milestone changed from Awaiting Review to Future Release
  • Severity changed from critical to normal
  • Type changed from defect (bug) to enhancement

When you disable the Extended Profile component, it means that you're disabling the ability for admins to set up custom profile fields. However, users still have a public profile, corresponding to the WordPress user profile. I'm not aware of a straightforward way to disable the display of the Public profile tab altogether. I guess it would be some combination of:

  • ensuring that Activity or something else was the default component
  • using bp_core_remove_nav_item() to remove the Profile tab

I'm going to move this into Future Release as an enhancement request, since probably there should be a better way to disable the display of profiles.

#3 @boonebgorges
10 years ago

  • Summary changed from Error in the flanges of the profiles to Profile tab cannot be easily disabled

#4 @seravifer
10 years ago

  • Component changed from Members to XProfile

How do the delete?

#5 @boonebgorges
10 years ago

Try the following in your bp-custom.php file:

function bbg_remove_profile_tab() {
  bp_core_remove_nav_item( 'profile' );
}
add_action( 'bp_setup_nav', 'bbg_remove_profile_tab', 99 );

#6 @seravifer
10 years ago

Not work:

<?php
define ( 'BP_DISABLE_ADMIN_BAR', true );
function bbg_remove_profile_tab() {
  bp_core_remove_nav_item( 'profile' );
}
add_action( 'bp_setup_nav', 'bbg_remove_profile_tab', 99 );
?>

#8 @johnjamesjacoby
10 years ago

  • Milestone Future Release deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Totally disabling the user profile isn't easily achieved in BuddyPress core. This is by design, as members need to have some kind of profile for the other components to use. Closing as wontfix; if you still need help, please start a support topic.

Note: See TracTickets for help on using tickets.