Skip to:
Content

BuddyPress.org

Opened 12 years ago

Closed 12 years ago

#3882 closed defect (bug) (fixed)

Cannot update Setting on the Settings page.

Reported by: fanquake's profile fanquake Owned by:
Milestone: 1.6 Priority: normal
Severity: critical Version:
Component: Administration Keywords:
Cc:

Description

I'm using the latest trunk, and am unable to update any of the settings in the 'Settings" menu.

That includes ticking new checkboxes and trying to save, and also unticking boxes that are already checked and trying to save.

Change History (4)

#1 @DJPaul
12 years ago

  • Milestone changed from Awaiting Review to 1.6

Confirmed. To clarify, this is on the wp-admin BuddyPress > Settings screen.

#2 @boonebgorges
12 years ago

This whole thing is, sadly, a big mess. I have a fix coming up shortly.

#3 @boonebgorges
12 years ago

There were a couple problems:

  • The Settings API save methods do not work with Multisite. That is, you can use add_settings_section() etc to display the markup, but there is nothing in WP that will automatically catch and save our settings on save when using MS (unlike options.php in non-MS). I'm implementing our own save routine for the moment. See #3835, #WP15691, #WP18285
  • In r5524, some new settings were registered that may have been intended to supplant some of our old settings. For example, I assume that _bp_avatar_upload is supposed to replace bp-disable-avatar-uploads. However, this was not fully implemented, and no work has been done to actually do the replacement throughout BuddyPress. For the moment, I'm leaving the code that registers these settings, but we will not be using them for BP 1.6.
  • There were a few logic errors related to checked() and the fact that some of our BP settings say the opposite of what the UI says (for instance, our UI says "Enable profile sync?" but the saved setting is 'bp-disable-profile-sync'.

These changes mean that the settings now work. That's where it should stand for BP 1.6. In the future, we will have to make some decisions as a team: Are we going to fully migrate to the Settings API (note that we cannot until it's fixed for Multisite)? Are we going to migrate to the new settings keys (_bp_avatar_upload etc), and if so, how are we going to manage backpat? Etc.

#4 @boonebgorges
12 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [5585]) Refactors the way that our Settings panel is saved, so that it does not rely on options.php and the WP Settings API to save submitted values.
Fixes some documentation related to the admin settings
Fixes some logic related to checked() in bp_admin_setting_callback_account_deletion()
Fixes #3882

Note: See TracTickets for help on using tickets.