Skip to:
Content

BuddyPress.org

Opened 8 years ago

Closed 8 years ago

#3787 closed defect (bug) (fixed)

Spamming a user from wp-admin does not remove user from groups

Reported by: johnjamesjacoby Owned by: johnjamesjacoby
Milestone: 1.5.5 Priority: normal
Severity: normal Version: 1.5.3
Component: Administration Keywords:
Cc:

Description

Nick Momrick traced this back to us hooking 'bp_actions' onto 'wp' which isn't fired in wp-admin.

Should be investigated and fixed in 1.5.2.

Change History (6)

#1 @boonebgorges
8 years ago

  • Milestone changed from 1.5.2 to 1.5.3

#2 @boonebgorges
8 years ago

  • Milestone changed from 1.5.3 to 1.5.4

#3 @johnjamesjacoby
8 years ago

  • Milestone changed from 1.5.4 to 1.6
  • Version set to 1.5.3

Moving to 1.6 to get 1.5.4 out.

#4 @boonebgorges
8 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [5803]) Splits mark-as-spam/ham functions into action function and business function.
Introduces new functions to hook to WP core make_spam_user/make_ham_user hooks, so that BP spamming events are triggered from the Network Dashboard.
Fixes #3787

#5 @boonebgorges
8 years ago

  • Keywords needs-patch removed
  • Milestone changed from 1.6 to 1.5.5
  • Resolution fixed deleted
  • Status changed from closed to reopened

Reopening this ticket and moving to the 1.5.5 milestone so that it gets put onto the 1.5 branch.

#6 @boonebgorges
8 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [5805]) Refactors mark-as-spam/ham process, so that it works properly from Network Admin as well as front-end.
A port of r5803 to the 1.5 branch.
Fixes #3787.

Note: See TracTickets for help on using tickets.