Skip to:
Content

BuddyPress.org

Opened 10 years ago

Closed 5 years ago

#3788 closed defect (bug) (worksforme)

Appearance of Blogs on Sites and Members-Sites Pages

Reported by: broniors Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Blogs Keywords:
Cc: broniors

Description

I am working on a move from a wordpress multisite to a new installation with wordpress/buddypress multisite. I have created the new multisite from scratch (including loading plugins) and I am only importing post,categories etc from xml files.
Wordpress 1.3.2
Buddypress 1.5.1

I have been working through an issue relating to new users being added via the admin and not having detail updated with Buddypress (http://buddypress.trac.wordpress.org/ticket/3755). However in this investigation I think I might have found something else

I have found for users that there is a problem with the way the blogs appear on blog lists with buddypress. I have found that when the following 2 pages load they do not list the blogs however when a change is made to the order (via dropdown) they do. I am not sure if it relates to the blogs being private but I thought it was wise to raise it.

Test user
username/password: sampleuser (this user was created via the front end and added to the sites from the admin)

This user should see 2 subblogs - Student 1 {Parent 1} and Student 2 {Parent 1}. This can be seen from the admin bar dropdown under sites. However when you go to either of the pages below. It just lists the default site. However if you change the dropdown on the ordered by from the default to something else ... they appear.

http://ipersonalshopper.com.au/sites/
http://ipersonalshopper.com.au/members/sampleuser/blogs/

For some reason when the pages load initially they don't appear with the sub-sites. I thought it might be possible that this might also relate to how they were added (as per the first ticket) but now I am not so sure.

I have included a couple of screen shots as examples

  1. Sites page - Image A when it first loads and Image B after I changed order by to Alphabetical.

http://ipersonalshopper.com.au/wp-content/uploads/2011/12/bloglist-01-sites-A.jpg
http://ipersonalshopper.com.au/wp-content/uploads/2011/12/bloglist-01-sites-B.jpg

  1. Members Page - Image A when it first loads and Image B after I changed order by to newest.

http://ipersonalshopper.com.au/wp-content/uploads/2011/12/bloglist-02-members-A.jpg
http://ipersonalshopper.com.au/wp-content/uploads/2011/12/bloglist-02-members-B.jpg

Attachments (4)

bloglist-01-sites-A.jpg (86.5 KB) - added by broniors 10 years ago.
Screen Capture 1
bloglist-01-sites-B.jpg (88.4 KB) - added by broniors 10 years ago.
Screen Capture 2
bloglist-02-members-A.jpg (78.0 KB) - added by broniors 10 years ago.
Screen Capture 3
bloglist-02-members-B.jpg (95.8 KB) - added by broniors 10 years ago.
Screen Capture 4

Download all attachments as: .zip

Change History (7)

@broniors
10 years ago

Screen Capture 1

@broniors
10 years ago

Screen Capture 2

@broniors
10 years ago

Screen Capture 3

@broniors
10 years ago

Screen Capture 4

#1 @boonebgorges
10 years ago

  • Keywords reporter-feedback added
  • Milestone changed from Awaiting Review to Future Release

It's likely that this is theme based. Have you looked to see whether this happens in bp-default as well?

#2 @broniors
10 years ago

Thanks for looking into this.

I have tested this with the BuddyPress Default 1.5.1 template and have the same result.

I think it might relate to the sites being private. I am using Private Buddypress which means that only registered users for each sites can see the sub-sites. However I am not sure if this is the cause as when you change the 'order by' they appear.

#3 @mercime
5 years ago

  • Component changed from Core to Blogs
  • Keywords reporter-feedback removed
  • Milestone Future Release deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Closing this 5-year-old ticket. There is no such issue in current WP multisite installations.

Note: See TracTickets for help on using tickets.