Skip to:
Content

BuddyPress.org

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#3670 closed defect (bug) (fixed)

datebox error in translated bp

Reported by: mind1 Owned by:
Milestone: 1.5.1 Priority: normal
Severity: normal Version: 1.5
Component: Extended Profile Keywords:
Cc:

Description

datebox field on edit profile page doesn't work properly with translated bp

bp-xprofile-template.php: line 581

this gets translated month

$month = mysql2date( 'F', $date );

but then it is compared to english month, so correct month is never selected on edit page

$html .= '<option value="' . $eng_months[$i] . '"' . selected( $month, $eng_months[$i], false ) . '>' . $months[$i] . '</option>';

this should fix that

$month = mysql2date( 'F', $date, false );

Change History (5)

#1 @cnorris23
10 years ago

  • Keywords reporter-feedback added

Good catch! Can you confirm that your suggested fix works? Looking at the code, I agree that it should, but just want to make sure you've tested it. The core devs, and myself, all use english translation, so it's hard for us to test.

#2 @boonebgorges
10 years ago

Confirmed. The problem didn't appear on the 1.2 branch because we weren't using mysql2date().

I've installed a French language pack and confirmed the fix as well.

#3 @boonebgorges
10 years ago

  • Keywords reporter-feedback removed
  • Milestone changed from Awaiting Review to 1.5.1
  • Version set to 1.5

#4 @boonebgorges
10 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [5229]) Ensures that the saved Month option is selected when editing a datebox profile field in languages other than English. Fixes #3670. Props mind1

#5 @boonebgorges
10 years ago

(In [5230]) Ensures that the saved Month option is selected when editing a datebox profile field in languages other than English. Fixes #3670. Props mind1

Note: See TracTickets for help on using tickets.