Skip to:
Content

BuddyPress.org

Opened 8 years ago

Closed 8 years ago

#3459 closed defect (bug) (fixed)

BuddyPress 1.5-b2 and WordPress 3.2.1 -> Fatal error: Cannot redeclare add_filter()

Reported by: cyberwani Owned by:
Milestone: 1.5 Priority: critical
Severity: critical Version: 1.5
Component: Core Keywords:
Cc: cyberwani

Description

I am using WP3.2.1 with BuddyPress1.5b2. And on acivation it gives the following erro:
Fatal error: Cannot redeclare add_filter() (previously declared in /var/www/wpstd/wp-includes/plugin.php:65) in /var/www/wpstd/wp-includes/plugin.php on line 72

Please! help about this.

Attachments (1)

BuddyPress - wpstd - WordPress.png (248.7 KB) - added by cyberwani 8 years ago.

Download all attachments as: .zip

Change History (5)

#1 follow-up: @boonebgorges
8 years ago

  • Resolution set to invalid
  • Status changed from new to closed

It sounds like you must have downloaded a corrupted version of WordPress or something. BuddyPress does not declare the function add_filter() anywhere. For this reason, it can't be a BP bug.

Delete your WordPress files, download WP afresh, and reupload them.

#2 in reply to: ↑ 1 @cyberwani
8 years ago

  • Cc cyberwani added
  • Resolution invalid deleted
  • Status changed from closed to reopened

Replying to boonebgorges:

It sounds like you must have downloaded a corrupted version of WordPress or something. BuddyPress does not declare the function add_filter() anywhere. For this reason, it can't be a BP bug.

Delete your WordPress files, download WP afresh, and reupload them.

This happens while BuddyPress Installation wizard. When installation wizard comes to option "4. Theme" and we selects "Manually update current theme" it displays:

Fatal error: Cannot redeclare add_filter() (previously declared in /var/www/wpstd/wp-includes/plugin.php:65) in /var/www/wpstd/wp-includes/plugin.php on line 72.

And, next time when we selects the "Use BuddyPress Default" in "4. Theme", it works fine and wizard completed fine.

#3 @boonebgorges
8 years ago

  • Milestone changed from Awaiting Review to 1.5
  • Priority changed from normal to critical
  • Severity changed from blocker to critical

Thanks for the additional information. I can now see where the problem is.

FYI, the BuddyPress Template Pack has yet been updated for BP 1.5. It may work, but it may not.

#4 @boonebgorges
8 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [4948]) Use require_once() when requiring plugins.php and activating BP Template Pack during wizard. Reverts part of r4775; see #3367. Fixes #3459.

Note: See TracTickets for help on using tickets.