Skip to:
Content

BuddyPress.org

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#3328 closed defect (bug) (fixed)

My Blogs menu gets out of sync

Reported by: boonebgorges's profile boonebgorges Owned by:
Milestone: 1.5 Priority: minor
Severity: normal Version:
Component: Blogs Keywords: has-patch needs-testing
Cc:

Description

On a BP instance I run, I've noticed that the My Blogs menu occasionally loses track of a blog or two. In my experience, this has happened when the user in question is a Super Admin. I don't have any steps to reproduce at the moment, but I want to leave the ticket open for a bit to see if anyone else has seen the problem.

Attachments (2)

3328.001.diff (3.1 KB) - added by cnorris23 11 years ago.
3328.002.diff (2.9 KB) - added by cnorris23 11 years ago.

Download all attachments as: .zip

Change History (7)

#1 @DJPaul
11 years ago

Possibly related to #2964

#2 @johnjamesjacoby
11 years ago

  • Severity set to normal

Is it possible this happens on sites created inside WP vs created via the BuddyPress interface? I think I've ran into this a long while ago too.

#3 @cnorris23
11 years ago

  • Keywords has-patch needs-testing added

I think the main problem that this was occurring was that a user's blog cache wasn't being properly cleared, because the cache name was wrong. I've fixed that, added some phpDoc, and added and extra cache clearing function to handle blog deletion for just-in-casies.

@cnorris23
11 years ago

#4 @johnjamesjacoby
11 years ago

  • Milestone changed from Awaiting Review to 1.5
  • Resolution set to fixed
  • Status changed from new to closed
  • Version 1.2.8 deleted

Can we check this out for 1.5?

#5 @cnorris23
11 years ago

I don't know if you meant to close this, but just in case, I've updated the patch so that it will apply.

@cnorris23
11 years ago

Note: See TracTickets for help on using tickets.