Skip to:
Content

BuddyPress.org

Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#3089 closed defect (bug) (duplicate)

broken RSS feed

Reported by: chouf1's profile chouf1 Owned by:
Milestone: 1.2.9 Priority: normal
Severity: normal Version:
Component: Activity Keywords:
Cc:

Description

This bug still remains in 1.2.7 and 1.2.8...

rss feed is blank because of accent.
The following patch was given in the past but was never in the code.
So here it is again.

in bp-activity/bp-activity-templatags.php

line 1031:

$title = trim( strip_tags( html_entity_decode( utf8_encode( $content[0] ) ) ) );


replace by:

$title =  strip_tags(html_entity_decode( $content[0],ENT_COMPAT,"UTF-8"  )) ;

line 1071:

return apply_filters( 'bp_get_activity_feed_item_description', html_entity_decode( str_replace( '%s','', $content ) ) );

replace by

return apply_filters( 'bp_get_activity_feed_item_description',  html_entity_decode( str_replace( '%s', ' ', $content ), ENT_COMPAT,  'UTF-8' ) );

Change History (2)

#1 @r-a-y
12 years ago

  • Keywords rss feed removed
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #2194.

#2 @johnjamesjacoby
11 years ago

  • Milestone changed from Awaiting Review to 1.2.9
  • Severity set to normal

Moving closed ticket out of Awaiting Review.

Note: See TracTickets for help on using tickets.