Skip to:
Content

BuddyPress.org

Opened 11 years ago

Closed 10 years ago

Last modified 10 years ago

#2996 closed defect (bug) (fixed)

XProfile Tabs lack filter

Reported by: sushkov Owned by:
Milestone: 1.5 Priority: normal
Severity: Version: 1.2.6
Component: Extended Profile Keywords: xprofile_profile_group_tabs, filter
Cc: hugoashmore@…

Description

In [branches/1.2/bp-xprofile/bp-xprofile-templatetags.php#L590]

do_action( 'xprofile_profile_group_tabs' );
should be a filter in order to be able to manipulate data.

I can't change nor hide xprofile group tabs currently.

Thanks.

Change History (9)

#2 @DJPaul
11 years ago

  • Milestone changed from Awaiting Review to 1.3

#3 @djpaul
11 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [3663]) Add filter to bp_profile_group_tabs(). Fixes #2996

#4 @hnla
10 years ago

  • Cc hugoashmore@… added
  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Type changed from enhancement to defect

Sadly this enhancement introduces errors, for every valid group field there is generated an extra empty LI element, tried to pin it down but out of time, looks like the $i incremental is adding + 1 to each 'foreach' looped item.

I reverted the change manually and the issue is resolved.

Last edited 10 years ago by hnla (previous) (diff)

#5 @DJPaul
10 years ago

When you say an empty element, do you mean literally "<li></li>"?

#6 @hnla
10 years ago

Yep literally:

one for each genuine li element as I said above likely the way you re-factored things and the incrementing, check it on one of your test installs, don't think I'm going mad :)

#7 @djpaul
10 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [4451]) Fix typo in r3663. Fixes #2996 again

#8 @hnla
10 years ago

Can't believe I didn't spot that simple missing '/' looking for more complex reasons and overlooked the simplest one :(

#9 @DJPaul
10 years ago

It took me much too long to spot it, too!

Note: See TracTickets for help on using tickets.