Skip to:
Content

BuddyPress.org

Opened 14 years ago

Closed 14 years ago

Last modified 8 years ago

#2502 closed defect (bug) (fixed)

JS: bp_dtheme_hide_comments() doesn't work when using an AJAX request

Reported by: r-a-y's profile r-a-y Owned by:
Milestone: 1.2.6 Priority: normal
Severity: Version:
Component: Templates Keywords: has-patch
Cc:

Description

In the bp-default theme, when there are more than five root activity comments for an activity update, the latest five comments will be shown and the rest will be hidden.

However, when you click on any AJAX tab (eg. "All Members"), this doesn't work as expected.

The problem is the order in which bp_dtheme_hide_comments() is fired. The attached patch fixes this.

Btw, we need a new component in Trac specifically for the default theme ;)

Attachments (1)

2502.001.patch (730 bytes) - added by r-a-y 14 years ago.

Download all attachments as: .zip

Change History (4)

@r-a-y
14 years ago

#1 @johnjamesjacoby
14 years ago

  • Component changed from Core to Theme

'Theme' component added. Thanks for the patch r-a-y!

#2 @johnjamesjacoby
14 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [3130]) Fixes #2502 props r-a-y

#3 @DJPaul
8 years ago

  • Component changed from Appearance - Template Parts to Templates
Note: See TracTickets for help on using tickets.