Skip to:
Content

Opened 4 years ago

Closed 3 years ago

#2456 closed defect (bug) (fixed)

Wordpress 3.0 – Run Buddypress on Secondary Blog

Reported by: vantucker Owned by:
Milestone: 1.5 Priority: critical
Severity: Version:
Component: Core Keywords:
Cc:

Description

Wordpress 3.0 with Buddypress on a Secondary Blog profiles returns to members directory. I have defined the BP_Root_Blog to ID: 3 and it works besides the inability to see profiles. When I visit: http://example.com/BLOG3/BLOGTILE/members/username/ it displays the members directory. All the links in the admin bar are correct. I have tested Blog ID: 1 and Buddypress works prefect.

Change History (10)

comment:1 andrea_r4 years ago

just confirming the same happened to me.

comment:2 boonebgorges4 years ago

What version of BuddyPress? BP_ROOT_BLOG seems altogether broken on the current 1.3-bleeding trunk.

comment:3 vantucker4 years ago

Version 1.2.4.1

comment:4 robertosbf4 years ago

Same problem with version: 1.2.5.2

comment:5 boonebgorges3 years ago

Just had another look, and the problem is this (at least in the trunk). The latest trunk uses WP pages to display top-level components. Those pages are specific to the blog where you initially installed BuddyPress. If you install BP and then switch your BP_ROOT_BLOG, BP will recognize that it is already installed (thus skipping the setup process, as it will recognize the site option bp-db-version), but it won't actually work because the association between BP components and WP pages will not have been established yet.

I think that the solution is probably to do a better job at checking that BP is properly installed. Instead of the current
if ( get_site_option( 'bp-db-version' ) < constant( 'BP_DB_VERSION' ) ), BP should also check to see whether BP_ROOT_BLOG has an option bp-pages, and if not, then it should load the setup routine.

I will try to figure out a patch for this, but in the meantime here's my suggestion. Access your wp_sitemeta table and delete the option bp-db-version. That will force BuddyPress to reinstall its WP pages on your new BP_ROOT_BLOG (without deleting any of your existing data).

comment:6 DJPaul3 years ago

Boone, is this issue still open? I can't remember if this was covered when you were working on the upgrader a couple of months ago.

comment:7 boonebgorges3 years ago

  • Priority changed from major to critical

No, this is not fixed. It's actually sort of more broken, because of the way that the new Network Admin changes tho way pages are loaded on the BP Component Dashboard panel. Working on it now.

comment:8 boonebgorges3 years ago

Note: this will largely be fixed when #3144 is fully implemented

comment:9 boonebgorges3 years ago

I'm about to commit a fix that makes bp-pages setup (the Components admin screen) compatible with changing the BP_ROOT_BLOG. Switching the root blog will bring up admin notices informing the admin to activate a BP-compatible theme, and setup bp-pages manually on the Components screen.

comment:10 boonebgorges3 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [4257]) Enables the Components/Pages setup panel to work correctly when BP_ROOT_BLOG is set to something other than 1. Fixes #2456

Note: See TracTickets for help on using tickets.