Skip to:
Content

Opened 9 years ago

Closed 9 years ago

#2252 closed defect (bug) (fixed)

BuddyPress stops emails being sent

Reported by: brianterry10 Owned by:
Milestone: 1.5 Priority: trivial
Severity: Version:
Component: Messages Keywords: email
Cc: brianterry10, c00l2sv

Description

I've just installed a brand new WordPress on my site.

I had set it up so anyone can register.

Here's a screenshot that shows the general settings used...
http://img.skitch.com/20100327-fhpat1hdaawwqyf11ykisdeimf.jpg

I tested this with a new registration.

The email to give me my password was sent to me. The admin was also sent an email telling me that someone had signed up.

So far so good.

Then I installed BuddyPress 1.2.3 (the newest version).

No other plugins were installed. Everything was fresh out of the box.

I activated the BP theme, I changed the permalink structure to /%postname%/.

Everything was now installed and looked fine.

Here's a screenshot that shows the BuddyPress general settings page...
http://img.skitch.com/20100327-pm3at1uic66hpugante7axfas6.jpg

Now I began testing it by creating a new membership account.

When I create a new test account no email is sent with my confirmation email link. The admin did not receive any emails either. I created several test accounts using different email addresses on different servers. None received the confirmation email.

Also...

When a member comments on a blog post and comments are set to be moderated first. No email is sent to admin about the comment.

So it seems like BuddyPress is preventing emails from being sent out.

Change History (7)

#1 @brianterry10
9 years ago

  • Priority changed from normal to critical

#2 @brianterry10
9 years ago

  • Cc brianterry10 added

#3 @brianterry10
9 years ago

After looking into this in more detail I discovered the problem is caused by a potential hosting compatibility issue with BuddyPress.

As soon as I turned off the BuddyPress plugin WordPress was able to send out emails again.

I installed BuddyPress on a WordPress install on a different server with a different hosting company and it worked fine. BuddyPress didn't stop emails being sent out from that hosting account.

The compatibility issue is with BlueHost.com where BuddyPress prevents emails being sent out. They use cPanel whereas the other hosting company where BuddyPress works doesn't.

#4 @c00l2sv
9 years ago

I got a fresh instance of latest WordPress 2.9.2 and BP 1.2.3 and I registered an account, and the email was sent. So it works for me too.

#5 @c00l2sv
9 years ago

  • Cc c00l2sv added

#6 follow-up: @DJPaul
9 years ago

We're aware of BlueHost issues on the forums. Use this plugin and you should be good to go:

http://wordpress.org/extend/plugins/mail-from/

Let us know if it fixes the issue on your BlueHost please.

#7 in reply to: ↑ 6 @brianterry10
9 years ago

  • Priority changed from critical to trivial
  • Resolution set to fixed
  • Status changed from new to closed

Hi DJ Paul

Thanks for the link to the plugin!

It fixed the issue.

I appreciate your help.

Replying to DJPaul:

We're aware of BlueHost issues on the forums. Use this plugin and you should be good to go:

http://wordpress.org/extend/plugins/mail-from/

Let us know if it fixes the issue on your BlueHost please.

Note: See TracTickets for help on using tickets.