Skip to:
Content

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#2246 closed defect (bug) (invalid)

wp-signup.php doesnt work

Reported by: meerblickzimmer Owned by:
Milestone: 1.2.4 Priority: normal
Severity: Version:
Component: Core Keywords: reporter-feedback
Cc:

Description

since 1.2. doesnt work the signup-page. if i deactivate buddypress (plugin & theme) the signup works fine. but if buddypress is activated, i get a redirect to the home-page.

Change History (12)

comment:1 apeatling4 years ago

  • Resolution set to invalid
  • Status changed from new to closed

use /register as it replaces wp-signup.php with a skinnable page.

comment:2 follow-up: meerblickzimmer4 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

Thats the same probleme. And i tried also define ('BP_REGISTER_SLUG', 'myownslug' ); but it doesnt help. The "register"-link inside the adminbar is also missing.

comment:3 in reply to: ↑ 2 sbrajesh4 years ago

Replying to meerblickzimmer:

Thats the same probleme. And i tried also define ('BP_REGISTER_SLUG', 'myownslug' ); but it doesnt help. The "register"-link inside the adminbar is also missing.

have you enabled registration/new account. Please cross check, as register link should appear in adminbar if registration is enabled.

comment:4 cnorris234 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

Have you double checked to make sure registration is enabled, as sbrajesh has suggested? If you're using WPMU, you would look under Site Admin > Options. If you're using WP single, you would look under Settings > General. Getting redirected to the homepage when BP is activated, is the expected behavior if registrations are not enabled.

comment:5 meerblickzimmer4 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

Yes i have cross check this and yes, registration is enable. If i do just to thing: deactivate buddypress and activate another theme, registration works.

I get the problem with the upgrade to 1.2 and if you check the buddypress-forum, there a few people with this problem :-/

comment:6 apeatling4 years ago

Have you followed the upgrade instructions and installed the backwards compatibility plugin and added the define( 'BP_CLASSIC_TEMPLATE_STRUCTURE', true ); to your wp-config.php?

http://codex.buddypress.org/getting-started/upgrading-from-10x/

comment:7 meerblickzimmer4 years ago

I´m using the default buddypress theme. Yes, i´m following the upgrad-instruction. All worked fine with 1.1.

I tryed also BP_CLASSIC_TEMPLATE_STRUCTURE - but it doesn´t help (and i don´t need it because using the latest default theme).

comment:8 johnjamesjacoby4 years ago

What version of WordPress are you using? To fix the issue we need to be able to duplicate it as closely as possible.

comment:9 meerblickzimmer4 years ago

i use wpmu 2.9.2

comment:10 DJPaul4 years ago

  • Component changed from Activity to Core
  • Keywords reporter-feedback added
  • Priority changed from critical to normal
  • Resolution set to invalid
  • Status changed from reopened to closed

This is an issue specific to your install as no-one's been able to reproduce (certainly, I can't). Please create a post on the forums so we can all have a look into your issue and go from there. If it turns out to be a BuddyPress bug, we can re-open this ticket.

comment:11 meerblickzimmer4 years ago

ok. if you search inside the buddypress-forum you will finde some thread with the problem. look her http://buddypress.org/forums/topic/the-requested-url-register-was-not-found-on-this-server

comment:12 meerblickzimmer4 years ago

well, the solution is this one:

http://buddypress.org/forums/topic/registration-link-redirects-to-home-page

maybe you can include it per default?

Note: See TracTickets for help on using tickets.