Skip to:
Content

BuddyPress.org

Opened 4 months ago

Closed 4 months ago

Last modified 5 days ago

#9064 closed defect (bug) (wontfix)

[Bug Report] issue with bbPress Integration (Forum Tab)

Reported by: kainelabsteam's profile kainelabsteam Owned by: johnjamesjacoby's profile johnjamesjacoby
Milestone: Priority: normal
Severity: normal Version: 12.0.0
Component: Forums Keywords:
Cc:

Description

Dear BuddyPress Team,

I want to report a minor bug.

If you install bbPress too, so on the BuddyPress profile page, will appear automatically "Forums" tab. The tab has sub tab called "Favorites". Since the BP 12, if you click it, it will redirect to a 404 not found page because the slug automatically changed to "bp-member-activity-favorites" instead of "favorites". Kindly check screenshot below:

​https://ibb.co/GktXpP7

Can you tell me how to fix it?

Best Regards, KaineLabs Team.

Change History (2)

#1 @imath
4 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Hi thanks for your report.

You need to activate the ​BP Classic back compatibility Add-on for bbPress for now.

This issue should be resolved by bbPress. It would be fantastic if you could report it there ​https://bbpress.trac.wordpress.org/ πŸ™

#2 @jondeho01
5 days ago

I've encountered a minor bug when integrating bbPress with BuddyPress. After installing bbPress, a "Forums" tab appears automatically on the BuddyPress profile page, which includes a "Favorites" sub-tab. However, since updating to BuddyPress 12.0.0, clicking on the "Favorites" sub-tab results in a 404 Not Found error. The slug has changed from "favorites" to "bp-member-activity-favorites".

Here is a screenshot of the issue: [Screenshot](​https://ibb.co/GktXpP7)

Steps to Reproduce:

  1. Install and activate BuddyPress.
  2. Install and activate bbPress.
  3. Navigate to a BuddyPress profile page.
  4. Click on the "Forums" tab and then on the "Favorites" sub-tab.

Current Behavior:

  • Clicking the "Favorites" sub-tab redirects to a 404 Not Found page.

Expected Behavior:

  • Clicking the "Favorites" sub-tab should display the user's favorite forum posts without any errors.

Temporary Solution:

  • Activating the BP Classic back compatibility add-on for bbPress.

Additional Information:

Is there a more permanent solution or workaround for this issue? Has anyone else encountered and resolved this problem?

Last edited 5 days ago by jondeho01 (previous) (diff)
Note: See TracTickets for help on using tickets.