Skip to:
Content

BuddyPress.org

Opened 11 months ago

Closed 11 months ago

Last modified 9 months ago

#8971 closed defect (bug) (fixed)

Logged in/out Members WP Nav Menu is failing in 12.0.0

Reported by: imath's profile imath Owned by: imath's profile imath
Milestone: 12.0.0 Priority: normal
Severity: normal Version:
Component: Members Keywords: has-patch
Cc:

Description

Reported by @vapvarun here https://buddypress.org/support/topic/lets-prepare-the-buddypress-12-0-0-next-major-release/#post-330778

I tested and was able to reproduce. I confirm the issue

Change History (7)

This ticket was mentioned in PR #148 on buddypress/buddypress by @imath.


11 months ago
#1

  • Keywords has-patch added; needs-patch removed

As the 'bp_parse_query' is not fired inside WP Admin context, we need to use the bp_get_component_navigations() function instead of trying to access the Members primary BP_Core_Nav.

Trac ticket: https://buddypress.trac.wordpress.org/ticket/8971

#2 @imath
11 months ago

  • Owner set to imath
  • Resolution set to fixed
  • Status changed from new to closed

In 13547:

Adapt the BP Member WP Nav Menu items to the BP Rewrites API

When BP Rewrites are on, we need to use bp_get_component_navigations() to get the registered logged-in member's navigation items.

Props vapvarun

Fixes #8971
Closes https://github.com/buddypress/buddypress/pull/148

#3 @vapvarun
11 months ago

Hi @imath Please check all tabs once, seems the HTML structure with tab index bp_nav_menu_item-search is not getting replaced with bp_nav_menu_item-all

https://prnt.sc/noJOTHxtw_cT
Test Env:
PHP v8.1.2
Screencast: https://somup.com/c0j2QoAQXa

#4 @imath
11 months ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

What is your WordPress version?

Because, I'm not getting the All tab's content even in BP 11.2 with WordPress 6.3.

#5 @vapvarun
11 months ago

Sorry about that, I accidentally cloned from the old recipe which was using version 5.8.7.

#6 @imath
11 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

Ok I see what it is: it's because WordPress changed the output moving the class attribute after the id one see: https://core.trac.wordpress.org/changeset/55616/

It's another issue. I'm going to close this ticket as fixed and open another one to deal with this WP 6.3 change for BP 11.2 and up.

This ticket was mentioned in Slack in #buddypress by imath. View the logs.


9 months ago

Note: See TracTickets for help on using tickets.