Skip to:
Content

BuddyPress.org

Opened 2 years ago

Closed 2 years ago

#8638 closed defect (bug) (fixed)

Pending accounts not showing all field selections when viewing accounts since 10.0

Reported by: niftythree's profile niftythree Owned by: dcavins's profile dcavins
Milestone: 10.1.0 Priority: normal
Severity: normal Version: 10.0.0
Component: Members Keywords:
Cc:

Description

Hello,

Since updating to 10.0, when reviewing accounts in Users > Manage Signups, some fields (which are actually filled in) show as empty. This does not happen in 9.2.0. Looking further into it, it appears to occur on fields where multiple selections can be made, such as checkboxes and multi select boxes. However, once the account is activated, the fields display fine with all their selections.

We are using the Legacy pack.

Thanks. 🙂

Attachments (1)

8638.1.diff (657 bytes) - added by dcavins 2 years ago.
Correct reference to bp_members_admin_format_xprofile_field_for_display()

Download all attachments as: .zip

Change History (7)

#1 @imath
2 years ago

  • Owner set to dcavins
  • Status changed from new to assigned

Can you refresh my memory I don’t remember we were displaying these fields in 9.2, I think that’s a feature we added in 10.0 (modal box). @dcavins can you look at this?

#2 @dcavins
2 years ago

I see the issue is a bad self-reference to the formatting function. I'm sure I messed it up while re-prefixing all of the signup functions for the twentieth time. :) Patch to follow.

@dcavins
2 years ago

Correct reference to bp_members_admin_format_xprofile_field_for_display()

#3 @dcavins
2 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 13234:

Correct reference to bp_members_admin_format_xprofile_field_for_display().

When formatting an array-based xprofile field for display,
bp_members_admin_format_xprofile_field_for_display()
should refer to itself using the correct function name.

Props niftythree.

Fixes #8638.

#4 @dcavins
2 years ago

Thanks @niftythree for the report!

#5 @imath
2 years ago

  • Component changed from Core to Members
  • Milestone changed from Awaiting Review to 10.1.0
  • Resolution fixed deleted
  • Status changed from closed to reopened

Let's make this fix available in 10.1.0, also committing it to the 10.0 branch ☺️

#6 @imath
2 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 13237:

Correct reference to bp_members_admin_format_xprofile_field_for_display().

When formatting an array-based xprofile field for display, bp_members_admin_format_xprofile_field_for_display() should refer to itself using the correct function name.

Props niftythree, dcavins.

Fixes #8638 (branch 10.0).

Note: See TracTickets for help on using tickets.