Skip to:
Content

BuddyPress.org

Opened 2 years ago

Closed 2 years ago

#8624 closed defect (bug) (fixed)

The "Manage Opt-outs" tab looks bad on mobile.

Reported by: muhittinsahilli's profile muhittinsahilli Owned by: imath's profile imath
Milestone: 10.1.0 Priority: low
Severity: minor Version:
Component: Administration Keywords: has-patch
Cc: The, "Manage, Opt-outs", tab, looks, bad, on, mobile.

Description

The "Manage Opt-outs" tab looks bad on mobile.

It's fine on desktop but looks bad on mobile. I think you need to fix this. There may also be mobile admin.

İmage Check Please: https://prnt.sc/26k9tdd

Thanks,

Attachments (2)

Screenshot_20220127_205226.jpg (83.3 KB) - added by muhittinsahilli 2 years ago.
Please Check
8624.patch (1.4 KB) - added by oztaser 2 years ago.

Download all attachments as: .zip

Change History (7)

#1 @oztaser
2 years ago

  • Keywords has-patch added; needs-design-feedback removed

Hi @muhittinsahilli,

Thanks for rising this issue.

I can confirm BuddyPress 10 has this issue (the attached screenshots in this ticket are not BuddyPress 10)

WP_List_Table is hiding tabs after primary one on mobile screens. I suggest to set first column of our custom table as primary.

Member Invitations table also has this similar issue.

@oztaser
2 years ago

#2 @muhittinsahilli
2 years ago

Hi @oztaser,

Yes, this is BuddyPress 9.2.0.
I also tested on 9.2.0 to check if the issue is specific to 10.0. That's why I accidentally took a screenshot of version 9.2.0. I'm sorry for that.

It is absolutely important that it looks neat on mobile screens. Because sometimes laptops are not with us when we have urgent needs. We log in directly from mobile.

Thank you for your interest.

Last edited 2 years ago by muhittinsahilli (previous) (diff)

#3 @imath
2 years ago

Hi @oztaser

Thanks a lot for your patch, I believe it's the right way to go. I'll test it asap.

#4 @imath
2 years ago

In 13225:

Improve Opt-out & Invitation list tables mobile display

Props muhittinsahilli, oztaser

See #8624(trunk)

#5 @imath
2 years ago

  • Owner set to imath
  • Resolution set to fixed
  • Status changed from assigned to closed

In 13226:

Improve Opt-out & Invitation list tables mobile display

Props muhittinsahilli, oztaser

Fixes #8624 (branch 10.0)

Note: See TracTickets for help on using tickets.