Skip to:
Content

BuddyPress.org

Opened 5 weeks ago

Last modified 4 weeks ago

#8570 reopened defect (bug)

On Multisite Environment, Users Also Created and Showing on the Main Site. Is it normal?

Reported by: mandro Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0.0
Component: Registration Keywords:
Cc:

Description

Good Day,

On the default WordPress Multisite environment, if the user signup through the Default WordPress form, the account is created on the Sub Site only.

But with activated BuddyPress and a user register via BuddyPress Registration form, the account will be created double. On the Main Site and the Sub Site. Is this normal behavior from BuddyPress or a bug?

Best Regards.

Change History (4)

#1 follow-up: @imath
4 weeks ago

  • Milestone 9.2.0 deleted
  • Resolution set to worksforme
  • Status changed from new to closed
  • Version changed from 9.1.1 to 3.0.0

#2 in reply to: ↑ 1 @xrelmate1
4 weeks ago

Replying to imath:

It is, since 3.0.0 😉

See: https://buddypress.trac.wordpress.org/browser/trunk/src/bp-members/bp-members-functions.php#L2192

Could you tell me how to modify the code in order for it to function like the WordPress Signups?

And an explanation of the reasons BuddyPress changed, since 3.0.0 would be helpful as well.

Last edited 4 weeks ago by xrelmate1 (previous) (diff)

#3 @imath
4 weeks ago

Sure, you can add this code into a bp-custom.php file:

<?php
remove_action( 'bp_core_activated_user', 'bp_members_add_role_after_activation', 1 );

And a detailed explanation is available there #7565

#4 @xrelmate1
4 weeks ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Hi,
I did as you said:
https://prnt.sc/1t2o2yz
https://prnt.sc/1t2oazk

But still getting the user in my main site:
https://prnt.sc/1t2nygr

Am I doing something wrong?

Note: See TracTickets for help on using tickets.