Skip to:
Content

BuddyPress.org

Opened 6 months ago

Closed 5 months ago

#8481 closed defect (bug) (fixed)

WP 5.8 Wigdet Block Editor legacy preview doesn't fire the `init` hook

Reported by: imath Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Core Keywords: has-patch close
Cc:

Description

This causes some issues when previewing Legacy Members, Groups...

The $bp->members->table_name_last_activity is not defined, BP Taxonomies are not registered etc..

The right fix should probably consist in hooking 'bp_init' to 'the_widget' when the REST endpoint previewing a widget is requested. For now the attached patch simply avoids PHP notices.

Attachments (1)

8481.patch (1.2 KB) - added by imath 6 months ago.

Download all attachments as: .zip

Change History (7)

@imath
6 months ago

#1 @imath
6 months ago

  • Summary changed from WP 5.8 Block Editor legacy preview doesn't fire the `init` hook to WP 5.8 Wigdet Block Editor legacy preview doesn't fire the `init` hook

#2 @imath
6 months ago

  • Milestone changed from Up Next to 8.1.0

This ticket was mentioned in Slack in #buddypress by imath. View the logs.


6 months ago

This ticket was mentioned in Slack in #buddypress by imath. View the logs.


6 months ago

#5 @imath
6 months ago

  • Keywords close added

It looks like WordPress 5.8 fixed the issue. I'll keep the ticket opened until 5.8 RC is released and check it again.

#6 @imath
5 months ago

  • Milestone 8.1.0 deleted
  • Resolution set to fixed
  • Status changed from assigned to closed

Just checked against WP 5.8 RC. I confirm the issue is now fixed.

Note: See TracTickets for help on using tickets.