Skip to:
Content

BuddyPress.org

Opened 7 weeks ago

Closed 6 weeks ago

#8342 closed defect (bug) (fixed)

Issue with group activity filter

Reported by: etatus Owned by: imath
Milestone: 7.0.0 Priority: normal
Severity: major Version: 3.0.0
Component: Activity Keywords: has-patch reporter-feedback
Cc:

Description

I detected that in groups activity page the filter didn't work, so checking the code I realized that bp_current_action() and bp_nouveau_current_object() functions were returning 'home' instead 'activity', so the html select didn't work.

If I make changes to let 'home' be a valid value (equivalent to 'activity') in functions:

bp_nouveau_current_object()
bp_nouveau_get_filter_container_id()
bp_nouveau_get_filter_id()

from: buddypress/bp-templates/bp-nouveau/includes/template-tags.php

then the select works fine.

Attachments (1)

8342.patch (1.2 KB) - added by imath 7 weeks ago.

Download all attachments as: .zip

Change History (5)

#1 @imath
7 weeks ago

  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to 7.0.0
  • Version changed from 6.1.0 to 3.0.0

Thanks for your feedback @etatus 👍

I confirm. The issue is only happening if the Group's home page has been disabled from the customizer. I'll try to look at it asap.

@imath
7 weeks ago

#2 @imath
7 weeks ago

  • Keywords has-patch reporter-feedback added; needs-patch removed

BP Nouveau is using some data-attributes to check what ajax actions need to be performed. If the Group's front page is not used, Activities are displayed on Group's home page. But the data attributes for the object and filter were wrongly set to home.

To make sure filters are behaving the right way, we need to override the component's object and data filter to activity so that the data-attributes are set the right way into the markup.

8342.patch should fix the issue, can you confirm @etatus ?

#3 @etatus
7 weeks ago

The patch seems to work fine. Thank you!

#4 @imath
6 weeks ago

  • Owner set to imath
  • Resolution set to fixed
  • Status changed from new to closed

In 12703:

BP Nouveau: make sure activity filter change triggers an Ajax request

The BP Nouveau Template pack uses data-attributes to check what Ajax request needs to be performed. When the Group’s front page is disabled from the BP Nouveau customizer section, Activities are displayed on Group’s home page. It appeared the activity filter selector’s data-attributes were wrongly set to home.

To make this filter behaves the right way, we need to override the component’s object and data filter to activity into the bp_nouveau_current_object() template tag.

Props etatus

Fixes #8342

Note: See TracTickets for help on using tickets.