Skip to:
Content

BuddyPress.org

Opened 6 months ago

Closed 5 months ago

#8311 closed defect (bug) (fixed)

Bug in My friends counter

Reported by: etatus Owned by: imath
Milestone: 6.1.0 Priority: highest
Severity: critical Version: 3.0.0
Component: Templates Keywords: reporter-feedback needs-patch
Cc: diseniartelugo

Description

This is a follow-up to #8283.

After upating to 6.0.0 with this issue supposedly fixed, I've realized that this problem still happens in "My groups" counter (and also it should be checked counters of "My friends", "Notifications" and "Messages" despite I guess some of them probably never reach 1000).

Attachments (1)

8311.patch (6.5 KB) - added by imath 6 months ago.

Download all attachments as: .zip

Change History (8)

#1 @imath
6 months ago

Hi @etatus thanks for following up #8283

I'm looking at it right now.

@imath
6 months ago

#2 @imath
6 months ago

  • Component changed from Groups to Templates
  • Keywords has-patch reporter-feedback added
  • Milestone changed from Awaiting Review to 6.1.0
  • Version changed from 6.0.0 to 3.0.0

I confirm the issue. 8311.patch should fix it.

@etatus could you test the patch to double check it's ok for you?

#3 @etatus
6 months ago

I applied all the changes in 8311.patch and I can confirm that My groups tab title in groups directory page and member profile page shows the correct number of groups now. (Thank you!)

However, in my environment I can't know if the number of friends is correct because I don't have more than 999 members.

Last edited 6 months ago by etatus (previous) (diff)

#4 @imath
6 months ago

In 12669:

BP Nouveau: make sure to format the total objects count once only

This is a follow up of [12619] & [12634] to apply the fix to the "my blogs", "my notifications", "my groups" and "my friends" count.

props etatus

See #8311 (Branch 6.0)

#5 @imath
6 months ago

  • Owner set to imath
  • Resolution set to fixed
  • Status changed from new to closed

In 12670:

BP Nouveau: make sure to format the total objects count once only

This is a follow up of [12619] & [12634] to apply the fix to the "my blogs", "my notifications", "my groups" and "my friends" count.

props etatus

Fixes #8311 (Trunk)

#6 @diseniartelugo
5 months ago

  • Cc diseniartelugo added
  • Keywords needs-patch added; has-patch removed
  • Priority changed from high to highest
  • Resolution fixed deleted
  • Severity changed from major to critical
  • Status changed from closed to reopened

Hi, i have too a problem with Activity, Notifications, Friends, Groups in Nouveaou Template.
I put all the buttons in vertical mode, and when i click in one of them (it use to have a number on the right) when the page loads the bar of (for exmaple) Groups appear in top of the profile cover and dissapear from the left menu. And when you try to clic on other menu suddenly the grey bar goes huge and block any clickhttps://www.gimnasiosantiagodecompostela.fit/Captura.JPGhttps://www.gimnasiosantiagodecompostela.fit/Captura2.JPGhttps://www.gimnasiosantiagodecompostela.fit/Captura3.JPG
i try to add the changes you mention here but nothing happens

#7 @imath
5 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

Hi @diseniartelugo

  1. It's not the same issue, as you can see in this screenshot important numbers are formatted the right way. As a result, I believe you should have open a new ticket instead of reopening a fixed one.
  2. The same screenshot shows you I wasn't able to reproduce Groups appear in top of the profile cover and dissapear from the left menu so I believe it's not a BuddyPress issue but rather a theme or custom code one.

Please try to use a default WordPress Theme like Twenty Nineteen with no other plugins (or custom code loaded) than BuddyPress active to check if your issue is still there. If so, don't hesitate to open a new ticket providing as much information as possible on your WordPress configuration.

Note: See TracTickets for help on using tickets.