Skip to:
Content

BuddyPress.org

Opened 8 months ago

Closed 7 months ago

#8182 closed defect (bug) (fixed)

Nouveau template in TwentyTwenty: group Invite icon overlaps username

Reported by: pooja1210 Owned by: imath
Milestone: 6.0.0 Priority: normal
Severity: normal Version:
Component: Templates Keywords: has-patch 2nd-opinion
Cc:

Description

While creating a group and inviting the user to the group found that the invite icon is overlapping username.

Attachments (3)

icon-overlap.png (76.2 KB) - added by pooja1210 8 months ago.
8182.patch (506 bytes) - added by imath 8 months ago.
8182.2.patch (4.8 KB) - added by imath 7 months ago.

Download all attachments as: .zip

Change History (6)

#1 @imath
8 months ago

  • Component changed from Core to Templates
  • Keywords has-patch added
  • Milestone changed from Awaiting Review to 6.0.0
  • Summary changed from In Nouveau template - group Invite icon overlaps username to Nouveau template in TwentyTwenty: group Invite icon overlaps username

Hi @pooja1210

Thanks for your feedback, the problem is more BuddyPress has not enough place to display his layout in TwentyTwenty. We could adapt the template pack to this theme again of course, but I believe we should benefit from the align-wide theme support that introduced the Block Editor to get this space.

@imath
8 months ago

@imath
7 months ago

#2 @imath
7 months ago

  • Keywords 2nd-opinion added

In 8182.2.patch I'm adding a new control to the BP Nouveau customizer section to adjust BuddyPress main container's width if the theme is supporting align-wide.

Here's the customizer control:

https://cldup.com/JKOdSAWIRp.png

And here's the result (where the icon is not overlapping anymore):

https://cldup.com/pw9XZF3wOq.png

I believe it's better than force the wide alignment. What do you think ?

#3 @imath
7 months ago

  • Owner set to imath
  • Resolution set to fixed
  • Status changed from new to closed

In 12537:

Add a new customizer setting to adapt BP Layout to wide alignments

The blocks editor introduced the align-wide theme feature. For themes supporting this feature, the BP Nouveau template pack will now use the wide alignment to display its content by default. To manage this space use, BP Nouveau also includes a new customizer setting to edit this alignement into the BP Nouveau > General BP Settings section.

Props pooja1210

Fixes #8182

Note: See TracTickets for help on using tickets.