Skip to:
Content

BuddyPress.org

Opened 9 months ago

Closed 8 months ago

#8162 closed feature request (worksforme)

Search box should have clear(X) button for the better user experience

Reported by: krupajnanda Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0.0
Component: Templates Keywords: has-screenshots
Cc:

Description

We have multiple search boxes on various component like on members page, messages page, etc.

It would be great if we have the clear button to reset the text and it would save the user's time when there would be long string. It would become faster because the text would just get disappear on click of one the button.

Looking forward to know the thoughts of core team if the things are doable!

Attachments (2)

Messages_–_krupa_nanda_–_test_site.png (47.6 KB) - added by krupajnanda 9 months ago.
8162.png (42.3 KB) - added by imath 8 months ago.

Download all attachments as: .zip

Change History (5)

#1 @imath
9 months ago

  • Component changed from (not sure) to Templates
  • Milestone changed from Awaiting Review to Awaiting Contributions
  • Version changed from 5.0.0 to 3.0.0

Hi I think it depends on the browser. I believe the clear (X) appears when using chrome, in other words the search input should behave the way you expect in Chrome. But I agree It would be nice to have it no matter the browser.

Who's jumping in to suggest a patch?

#2 @krupajnanda
9 months ago

Hi @imath,

Actually I found that this issue is template-specific.

I believe the clear (X) appears when using chrome, in other words the search input should behave the way you expect in Chrome.

Legacy Template - It does not appear in any browser
Nouveau Template - It does not appear in Firefox browser

PS - I have checked this Chrome, Safari and Firefox browser

But I agree It would be nice to have it no matter the browser.

Yes, it would be really great to have this feature.

Last edited 9 months ago by krupajnanda (previous) (diff)

@imath
8 months ago

#3 @imath
8 months ago

  • Keywords needs-patch removed
  • Milestone Awaiting Contributions deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Hi @krupajnanda

I knew I wasn't losing my mind ! When I've been contributing to the BP Nouveau template pack I made sure clicking on the (x) control of a search input would reset the loops :)

So BP Nouveau includes this feature. The fact you don't see it is caused by the active theme. In my screenshot above, I've activated Twenty Nineteen and as you can see it's working great ;)

So you can probably bring it back using a child theme and making sure the search field appearance is reset to its default value.

I'm going to close this ticket as I believe we're already doing our job :) Thanks again for your feedback.

Note: See TracTickets for help on using tickets.