Skip to:
Content

BuddyPress.org

Opened 2 years ago

Closed 2 years ago

#8002 closed defect (bug) (worksforme)

bp_group_new_topic_button

Reported by: Venutius Owned by:
Milestone: Priority: lowest
Severity: trivial Version: 3.0.0
Component: Core Keywords:
Cc:

Description

If been getting quite an annonymous error message when in the group manage page:

wp-content/plugins/buddypress/bp-core/deprecated/3.0.php:77 - bp_group_new_topic_button is deprecated since version 3.0! Use legacy forum support removed instead.
require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/themes/graphene/page.php'), get_template_part, locate_template, load_template, require('/themes/graphene/loop-page.php'), the_content, apply_filters('the_content'), WP_Hook->apply_filters, bp_replace_the_content, apply_filters('bp_replace_the_content'), WP_Hook->apply_filters, BP_Groups_Theme_Compat->single_content, bp_buffer_template_part, bp_get_template_part, bp_locate_template, load_template, require('/plugins/buddypress/bp-templates/bp-legacy/buddypress/groups/single/home.php'), bp_get_template_part, bp_locate_template, load_template, require('/plugins/buddypress/bp-templates/bp-legacy/buddypress/groups/single/cover-image-header.php'), do_action('bp_group_header_actions'), WP_Hook->do_action, WP_Hook->apply_filters, bp_group_new_topic_button, _deprecated_function

I did a trawl of my codebase and found it used once in the current Beta code:

buddypress/bp-themes/bp-default/functions.php line 132:

add_action( 'bp_group_header_actions', 'bp_group_new_topic_button', 20 );

Attachments (1)

IMG_20190209_194801.jpg (3.4 MB) - added by alexander1442 2 years ago.

Change History (3)

#1 @Venutius
2 years ago

  • Priority changed from normal to lowest
  • Severity changed from normal to trivial

Ah sorry please ignore this, that wasn't the cause of the issue, that's a legacy file that's not being loaded.

#2 @boonebgorges
2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Thanks, @Venutius !

Note: See TracTickets for help on using tickets.