Skip to:
Content

BuddyPress.org

Opened 2 years ago

Closed 2 years ago

#7994 closed defect (bug) (fixed)

Register.php HTML bug

Reported by: mo3aser Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0.0
Component: Templates Keywords:
Cc:

Description

Hi there,

In the bp-nouveau/buddypress/members/register.php file, the close of div .layout-wrap is inside this if condition

<?php if ( 'request-details' === bp_get_current_signup_step() ) : ?>

So when we are in any other step than the "request-details" such as the "completed-confirmation" the close </div> tag will be missing and that will break the HTML structure of the page causes issues with some themes.

We need to move the <div class="layout-wrap"> inside the same if condition or move the close tag outside if just before the close of the <form>

Best regards
Best regards

Change History (1)

#1 @r-a-y
2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to fixed
  • Status changed from new to closed

Duplicate of #7973.

@mo3aser - Can you check out that ticket and see if that fixes things for you?

Here's the updated register.php if you want to test:
https://buddypress.trac.wordpress.org/browser/branches/3.0/src/bp-templates/bp-nouveau/buddypress/members/register.php

Note: See TracTickets for help on using tickets.