Skip to:
Content

BuddyPress.org

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#7886 closed defect (bug) (no action required)

wp bp group list command shows hidden group also

Reported by: 1naveengiri's profile 1naveengiri Owned by:
Milestone: Priority: high
Severity: normal Version: 3.0.0
Component: Core Keywords: close
Cc:

Description

Issue

Based on hidden group description on create group tab

This group will not be listed in the groups directory or search results.

but seems wp bp group list command list hidden group also.

Attachments

https://snag.gy/c2pHni.jpg

https://snag.gy/WrN6iq.jpg

Change History (3)

#1 @DJPaul
6 years ago

WP-CLI is a server-side admin tool, so my expectation would be that you can see everything via the commands.
If I have server access, I can probably access the database directly anyway, so nothing is private at that point.

#2 @boonebgorges
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Hi @1naveengiri - Thanks for the ticket, and thanks for using the CLI commands!!

This behavior is by design. WP-CLI commands are meant to reproduce actions you can perform "in the admin" https://wp-cli.org/, which is to say that they are actions performed by an administrator. And site administrators can see all BP content, including hidden groups.

Think of it this way: Anyone with access to perform a CLI command on a BP server has the ability to access the database directly. So there's no privacy issue here.

#3 @espellcaste
6 years ago

  • Keywords close added; needs-patch removed

Closing as invalid!

And thanks @1naveengiri for using BuddyPress cli commands! :D

Note: See TracTickets for help on using tickets.