Skip to:
Content

BuddyPress.org

Opened 16 months ago

Closed 16 months ago

Last modified 16 months ago

#7831 closed defect (bug) (fixed)

Friendship Requested button on member's profile doesn't respond anything

Reported by: Ankit K Gupta Owned by: imath
Milestone: 3.0 Priority: normal
Severity: normal Version:
Component: Templates Keywords: has-patch commit
Cc:

Description

Use Case Scenario: when member gets friendship request from another member and try to accept. He/She can not.
Previously this button redirects to All request page i.e. '/friends/requests/' but in BP 3.0 <a> has been removed due to any reason.

To be more specific, please watch these links:

With BP RC 3.0: https://screencast-o-matic.com/watch/cFho1cbaUW
With BP 2.9.4: https://screencast-o-matic.com/watch/cFho11bavI

Attachments (2)

Screenshot of Gupta Ankit .jpg (73.4 KB) - added by Ankit K Gupta 16 months ago.
screenshot of member profile
7831.patch (866 bytes) - added by imath 16 months ago.

Download all attachments as: .zip

Change History (10)

@Ankit K Gupta
16 months ago

screenshot of member profile

#1 @imath
16 months ago

  • Component changed from Friends to Templates
  • Keywords has-patch added

Hi @Ankit K Gupta

I confirm. Nice catch. Thanks a lot for your feedback about it. FYI That's specific to the Nouveau template. If you switch back to the Legacy template you should get the right behavior for this button. That's why i changed the Component to templates.

7831.patch is a first patch that should fix the issue. But I need to carry on investigating about it to see if the patch can be improved.

Last edited 16 months ago by imath (previous) (diff)

@imath
16 months ago

#2 @imath
16 months ago

  • Keywords 2nd-opinion added

@hugo checking this https://github.com/buddypress/next-template-packs/commit/d223aec30cc1bf92f0d7218b5ef9382e1b4edfd6#diff-8a859e585ba96d39d84477b7703a0dfe It looks like the button element is a layout choice. So I guess the 7831.patch is the best way to fix it without changing too many things.

#3 @DJPaul
16 months ago

I’m happy to accept the current version of the patch into 3.0, once it’s OK’d by another core team member.

#4 @imath
16 months ago

Thanks for your feedback @DJPaul I totally agree I’d feel safer with @hnla ‘s opinion on it 😊

#5 @hnla
16 months ago

@imath having a quick look.

#6 @hnla
16 months ago

  • Keywords commit added; 2nd-opinion removed
  • Milestone changed from Awaiting Review to 3.0

@imath yep agree on patch, the element was part of the somewhat tricky markup switching between button element and anchors where appropriate and providing additionally as user option, proved a burden to try and get right in the end. Testing the patch and scanning the function and it all seems good, expected behaviour is returned and function logic looks correct, I would commit the patch.

@Ankit K Gupta Nice catch thanks for spotting and reporting.

#7 @imath
16 months ago

  • Owner set to imath
  • Resolution set to fixed
  • Status changed from new to closed

In 12092:

BP Nouveau: use a link for the awaiting response friendship button.

This makes sure the logged in user can view and reply to his friendship requests.

Props ankit-k-gupta, DJPaul, hnla

Fixes #7831

#8 @Ankit K Gupta
16 months ago

Hello @imath @hnla,

Thank you for your kind words it means a lot to me! :)

Note: See TracTickets for help on using tickets.