Skip to:
Content

BuddyPress.org

#7760 closed feature request (maybelater)

Synchronise Buddypress and most WordPress profile information

Reported by: normancates Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Core Keywords:
Cc:

Description

Hi ya,
Over the last while I’ve REALLY been struggling with the disparity between the WP profile info and BP profile info.

BP only has a Name field. But WP has quite a few profile fields that are very useful.

It would be incredibly helpful to have the option to have pretty much the same fields in BP as are in the WP profile. This would mean that users would have only one place to go to change information and could stay in Buddypress.

We could change our display name. We could change nicknames and so on.

It’s incredibly confusing for everyone that the Profile info does not do a two way sync between these two areas.

There are paid (expensive) plugins that can do the two way sync. There are free plugins that can do the BP->WP sync.

I can see that if you have Buddypress sub sites and they are acting as their own site, with separate information from the other subsites, then how to make that work is an issue.

But yeah. Even if that’s an edge case, it would be SO HELPFUL to be able to have reliable sync both ways.

Cheers,
Norm

Change History (4)

#1 @DJPaul
18 months ago

Hi @normancates

Thanks for getting in contact. Before I respond, I will clarify that BuddyPress does split up its default "Name" field and syncs it into WP's "nickname", "first_name", "last_name", and "display_name" fields. This is a pretty basic sync (it splits up the Name field, based on spaces in it).

Conversely, if you change WP's "display_name" field, that gets sync'd back into BuddyPress' default "Name" field.

I agree it would be neat to be able to drop in WP's default profile fields into the BP profile settings (e.g. Biography, etc). As part of that, we'd put proper/better syncing controls/behaviour in.

Is that sort of what you had in mind?

#2 @r-a-y
18 months ago

Duplicate of #7162?

#3 @normancates
18 months ago

Yeah, that's pretty much what I think would be really helpful.

It already happens with password and email...

I've never had any joy with WP and BP synchronizing data. It doesn't seem to push either way.

This could be because of my previously mentioned use of Multisites and Keeping the themes in each site separate.

I'm very skeptical of any algorithms ability to correctly decide how to deal with a name and split it correctly except in pretty trivial cases.

I'm sure the reasons for only having Name in Buddypress are lost in the mists of antiquity. But I really do think that it should reflect much more closely the standard Wordpress profile fields.

Thanks,
Norm

#4 @DJPaul
18 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to maybelater
  • Status changed from new to closed

We have this suggestion logged in different forms in other tickets such as #7162, so I'm going to close this one because we don't need another one.

Thanks for the feedback!

Note: See TracTickets for help on using tickets.