Skip to:
Content

Opened 14 months ago

Closed 13 months ago

Last modified 13 months ago

#7653 closed enhancement (no action required)

WPCS improvements to the Admin Component Options

Reported by: espellcaste Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Core Keywords: has-patch
Cc:

Description

While working on the list command for wp-cli-buddypress, I sensed bp_core_admin_components_options could be improved. Patch eminent. :)

Attachments (1)

7653-1.diff (10.1 KB) - added by espellcaste 14 months ago.

Download all attachments as: .zip

Change History (7)

@espellcaste
14 months ago

#1 @espellcaste
14 months ago

  • Type changed from defect (bug) to enhancement

#2 @DJPaul
14 months ago

This looks ok but if you got this from running PHPCS/PHPCBF, I am up for an effort like #WP41057 on our codebase -- after @r-a-y lands #7218 otherwise his patches are going to be a nightmare to update. :(

Last edited 14 months ago by DJPaul (previous) (diff)

#3 @espellcaste
13 months ago

  • Milestone 3.0 deleted
  • Resolution set to invalid
  • Status changed from new to closed

Makes total sense! I'm closing this now as invalid and I'll think about doing what was done on #WP41057.

Thank you for the feedback Paul. :)

#4 @DJPaul
13 months ago

The patch is easy (really, just copy in WP's PHPCS file), the issue is reviewing every single change (there's thousands of changes) and checking we agree with the relevant coding standard, while not breaking any sizeable patch still in progress. Right now, I only know of Ray's set of patches that would be seriously inconvenienced by doing this.

I will probably start doing it piecemeal - I might do Nouveau first, before I dive into another round of code reviews on that.

#5 @netweb
13 months ago

Yup, pretty much that, I've not started on this either as waiting for WPCS 1.0 to be released rather than playing with branches in composer.json, once WPCS 1.0 is released we can start seeing how things look,

Was that some trailing commas I wrote, @jjj has opinions on this, i.e, something about someplace freezing over before these get committed in the bb's... a couple more tweaks will also be required that I can't remember off the top of my head right now

#6 @johnjamesjacoby
13 months ago

I don’t want this to turn into the JJJ styleguide, but it’s obviously true that I have strong opinions on how elegant code is best written, and I’ve been irresponsible by not publishing those someplace to make them more clear.

In short, it’s like having a nice signature – it’s almost meaningless until people compliment you on it, but you won’t want to change it once they start, and there’s no other real reason to practice it when the reality is you can just sign an X.

We can build tools to recreate coding standards, but that will never beat the zen-like practice of strolling through code and reflecting on every nuanced character choice.

It’s an exercise that isn’t appealing to everyone, but it’s important to me, and an important part of what I selfishly enjoy teaching others.

Last edited 13 months ago by johnjamesjacoby (previous) (diff)
Note: See TracTickets for help on using tickets.