Skip to:
Content

Opened 21 months ago

Last modified 17 months ago

#7320 reopened defect (bug)

Group header: warning in admins/mods list

Reported by: JeffWillia.ms Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Groups Keywords: dev-feedback close
Cc:

Description

Hello,

All the Groups I create display this error across the Group Profile:

Warning: Creating default object from empty value in /home/swiftbus/public_html/5firemen.com/wp-content/plugins/buddypress/bp-groups/classes/class-bp-groups-member.php on line 1122

I attached a snapshot for your reference.

Any idea what the issue is and how to fix it?

Thanks

Attachments (1)

Capture.JPG (152.7 KB) - added by JeffWillia.ms 21 months ago.

Download all attachments as: .zip

Change History (21)

#1 @slaFFik
21 months ago

  • Keywords reporter-feedback added
  • Priority changed from high to normal
  • Severity changed from major to normal
  • Version 2.7 deleted

@JeffWilliams

Are you sure that you don't have a plugin or code, that adds users to groups when they are created? Or somehow differently modifies groups admins/moderators list?
I can't replicate with BuddyPress 2.7.1.

Last edited 21 months ago by slaFFik (previous) (diff)

#2 @slaFFik
21 months ago

  • Summary changed from Group Display Error to Group header: warning in admins/mods list

#3 @mercime
21 months ago

@JeffWillia.ms Could be a theme-related issue. When did you last update your Kleo theme?

#4 @JeffWillia.ms
21 months ago

  • Keywords reporter-feedback removed

Hey @slaFFik and @mercime

Thanks for the reply guys!

@slaFFik Yes, I'm sure I do not have a plugin or code that adds users to groups when they are created, or modifies group admins/moderators. I turned off all my plugins, one by one, to test it. None of my plugins seemed to have caused the problem.

@mercime Kleo theme is up to date. That's something I stay on top of. I've also been working directly with Kleo support on this. They are actually the ones who suggested it's BP issue, and that I should create a support ticket here. Lastly, I switched to the WP 2106 default theme and received the same error, so I don't think it's the theme.

Thougths?

Thanks for your help. Really appreciate it.

#5 @DJPaul
20 months ago

@JeffWillia.ms Could you list all plugins you have active on the site? Are you using anything for object cache support, or any other kind of cache?

The line number reported is a very strange place to get this sort of warning, which is why it's non-obvious to track down.

#6 @slaFFik
20 months ago

  • Keywords reporter-feedback added

#7 @slaFFik
20 months ago

@JeffWillia.ms
Do you have object cache enabled? With a /wp-content/object-cache.php file.
Does the issue persist when creating a new group?

#8 @JeffWillia.ms
20 months ago

  • Keywords reporter-feedback removed

Hello @DJPaul and @slaFFik

@DJPaul

Active plugins include:
404 to 301
Akismet
bbPress
BuddyPress
BuddyPress Username Changer
Google Analytics by MonsterInsights
Google XML Sitemaps
Gravity Forms
Gravity Forms No CAPTCHA reCAPTCHA
iThemes Security Pro
Jetpack by WordPress.com
Paid Memberships Pro
Paid Memberships Pro - AWeber Add On
Paid Memberships Pro - bbPress Add On
Paid Memberships Pro - WooCommerce Add On
Regenerate Thumbnails
rtMedia for WordPress, BuddyPress and bbPress
SG CachePress
Sucuri Security - Auditing, Malware Scanner and Hardening
WangGuard
WooCommerce
WordPress Importer
WP Smush
Yoast SEO

My host is Site Ground. I use their caching plugin, SG SuperCacher, which is designed to work with their servers.

@slaFFik yes, when I create a new group, the problem persists. I'm not familiar with how to enable object cache.

Thanks for the replies.

Cheers!

#9 @slaFFik
20 months ago

  • Keywords reporter-feedback added

I'm on SiteGround as well, they do have object cache plugin which uses Memcache, but I don't have this problem on a live site.

Are you sure, that the issue is still valid on your site with these prerequisites:
1) you have only BuddyPress plugin of the latest stable version activated - none of other plugins
2) you have 2016 theme activated with no extra not default code in functions.php
3) there is no /wp-content/bp-custom.php file
4) there are no .php files in /wp-content/mu-plugins/

#10 @JeffWillia.ms
20 months ago

  • Keywords reporter-feedback removed

Hi @slaFFik

  1. I am sure BP is the latest version, and all plugins/themes are up to date. I am militant about that. :-)
  1. I have the 2015 theme. No extra code in the functions.php file
  1. There is no /wp-content/bp-custom.php file
  1. I do not have a /wp-content/mu-plugins/ location in my directory. Does not exist.

#11 @slaFFik
20 months ago

  • Keywords reporter-feedback dev-feedback added

@JeffWillia.ms

I still can't replicate. I assume (as you didn't reflect that in your reply) that you have only 1 plugin activated - BuddyPress 2.7.2.
I've tested BP 2.7.2 on SiteGround with object cache enabled (actually, all of their 3 caches).

I would close this ticket if we didn't have chance to replicate it.

#12 @JeffWillia.ms
20 months ago

  • Keywords reporter-feedback removed

@slaFFik

As I mentioned in this thread (reply #4, answering your question) I have already turned off all plugins, etc. to test the issue.

I understand that you can't replicate it, which makes finding the problem difficult. However that does not mean there's not a problem. There's a lot of other people having the same issue. See this post:

https://buddypress.org/support/topic/group-header-file-problems/

Wouldn't make a lot of sense to just close/ignore the problem, because you can't replicate it.

Cheers.

#13 @slaFFik
20 months ago

@JeffWillia.ms

I hope you understand, that we can't fix blindly when we can't replicate.

@dcavins
I see that in that forum thread you contacted reporter, are there any additional details on this issue?

Last edited 20 months ago by slaFFik (previous) (diff)

#14 @JeffWillia.ms
20 months ago

@slaFFik I didn't have any expectations at all. I simply reported the issue in the place you're supposed to report it to.

@dcavins Nope, it never went anywhere after that. To my knowledge, there's still no resolution.

#15 @JeffWillia.ms
20 months ago

@slaFFik @DJPaul @mercime @dcavins

Some interesting news with this. Per your suggestions that the issue might be related to my host's caching, I wrote Site Ground Support and asked them to check into the problem. Her reply is below:

"I was able to load the page in Mozilla and Safari with no resolving errors. However, once I opened it with Google Chrome, the error appear. I have cleared the application cache and deactivated plugins, however, to no avail. The issue is not server related it is an issue with the code"

After receiving her reply, I went and tested her findings for myself. Indeed, she was right. However, the investigation with different browsers must have caused a "break thru" with Chrome, because it no longer shows the error. This is true for multiple sites I manage that had the same issue.

Not sure why that solved the problem, but thought I'd let you guys know about it since you are more technically savvy than I.

Thanks for taking the time to help.

Cheers.

#16 @slaFFik
19 months ago

  • Keywords close added
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Personally I currently don't have ideas of the reasons.
As noone of developers was able to replicate the issue, I propose to close this thicket as worksforme.

#17 @slaFFik
19 months ago

  • Resolution changed from invalid to worksforme

#18 @ryanrain
18 months ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

hey good people, i've hit this error too, and have some info to add which should hopefully help reproduce the issue.

My setup: wp 4.7.1, bp 2.7.4, php 7.0, *REDIS OBJECT CACHING VIA W3TC*

i'm convinced this is an object caching issue:

  • i'm using a buddyboss child theme, but have also been able to reproduce this issue in twenty seventeen.
  • this is server-side. i've been able to see this in firefox as well, *but* the error doesn't show 100% of the time due to whether the data served comes from cache or not.
  • the error shows while object cache via redis is enabled in w3tc, but disappears when that option is disabled.

Hope this helps! sorry i don't have the smarts or time to dig in further, but at least i can provide another data point! object caching is crucial to decent performance for our member-only site, so hopefully this can be resolved. many thanks!
-r

#19 @otismrt
18 months ago

same here: /public_html/wp-content/plugins/buddypress/bp-groups/classes/class-bp-groups-member.php on line 1122

#20 @miguelangeltorresfp
17 months ago

Hi,

I have the same issue on my site.

I'm on Siteground too with object cache enabled.

For now I've had to add a moderator to every group in order to get rid of this warning.

Thanks for your help.

Cheers.

Note: See TracTickets for help on using tickets.