Skip to:
Content

BuddyPress.org

Opened 8 years ago

Closed 8 years ago

#6928 closed enhancement

Improve error messaging on profile edit screens.

Reported by: dcavins's profile dcavins Owned by:
Milestone: Priority: low
Severity: minor Version: 2.4.0
Component: Extended Profile Keywords:
Cc: dcavins

Description

On the registration form, we provide specific error messages by adding text describing the problem above the problem fields. On a user's profile > edit screen, we only provide a blanket error banner: it either worked or failed.

It'd be great to add specific error messages to the profile edit screen. It also doesn't seem like it would a huge project, but it'd be helpful if we could discuss the best way to do it.

  • Do we love passing error messages via $bp->signup->errors[$field_name]?
  • Would it make sense to handle the registration form and the profile edit screen using the same validation process so that you could handle validation for a field (like a ZIP code or phone number) and have it work in both places? (Although maybe the answer to that question is to add a "custom regex" meta for each field so it can be added via the wp-admin interface. But off topic.)

Thanks for your feedback.

Attachments (2)

profile-field-error-registration.png (14.2 KB) - added by dcavins 8 years ago.
Error banners on the registration screen are specific and helpful.
profile-field-error-edit-screen.png (45.5 KB) - added by dcavins 8 years ago.
Error banners on the profile edit screen are sorta vague.

Download all attachments as: .zip

Change History (4)

@dcavins
8 years ago

Error banners on the registration screen are specific and helpful.

@dcavins
8 years ago

Error banners on the profile edit screen are sorta vague.

#1 @r-a-y
8 years ago

I believe this is the same issue as #5738. #5738 goes a bit into the technical aspects of the problem.

#2 @dcavins
8 years ago

  • Milestone Awaiting Review deleted
  • Status changed from new to closed

Closed as duplicate of #5738, which I didn't find when searching trac. Thanks for pointing out that other ticket, @r-a-y.

Note: See TracTickets for help on using tickets.