Skip to:
Content

BuddyPress.org

Opened 8 years ago

Closed 6 years ago

#6824 closed enhancement (maybelater)

Enhancement for my account adminbar dropdown link

Reported by: sbrajesh's profile sbrajesh Owned by:
Milestone: Priority: low
Severity: minor Version:
Component: Toolbar & Notifications Keywords: needs-patch, trac-tidy-2018
Cc: sbrajesh

Description

When WordPress adminbar is enabled, The right side "Howday, Username" link and the avatar & name, Edit profile, All three links point to edit profile page.

This is not a bug in BuddyPress but an enhancement request. Can we please links "Howday, Username" to the User landing page(user activity), Name/avatar to the user profile and leave the edit profile as it is.

Here is how I have accomplished it for now.
http://buddydev.com/buddypress/enhancing-my-account-menu-with-buddypress-in-the-adminbar/

If the request is accepted, I can put a more BuddyPress oriented patch.

Thank you
Brajesh

Change History (10)

#1 @imath
8 years ago

Hi @sbrajesh,

This is my humble opinion about this :

1/ I agree that "howdy username" link would be best if it was landing on http://site.url/members/username/
2/ I think i would rather the avatar and name to also link to http://site.url/members/username/
3/ Finally the Edit My Profile link should link to http://site.url/members/username/profile/edit if the xProfile component is activated and and to http://site.url/wp-admin/porfile.php when it's not activated.

#2 @hnla
8 years ago

Agreed it should be updated.

Think I agree with imath, linking to user index.

There is a clear and distinct text link to edit profile, there should be no other links to this screen ( other than the main drop down list), we're in danger of running foul of too many 'same' links, just because there's a piece of text that could link somewhere doesn't mean it has to, but hey ho.

Lets patch this!

#3 @sbrajesh
8 years ago

Thank you @imath and @hnla for the feedback.
I too agree that in the core implementation let us keep the links to /username instead of being specific to profile.

If someone needs that, they can always override that. We don't need to touch the edit profile link here as BuddyPress core is already handling it properly. So, the only concern were the other two links.

I will add a patch today. Any suggestions for the right place to patch, should I add it in bp-core-adminbar.php or bp-members-adminbar.php?

#4 @imath
8 years ago

@sbrajesh that's interesting, i advise you to look at bp_members_edit_profile_url(), because this is the function that is dealing with the links you're targeting.

This part is built by WordPress and we're simply filtering the link, reason why all links are identical.

But to reply to your question, i'd say bp-core-members-adminbar.php.

Thanks in advance for your patch and work on this ticket.

#5 @hnla
8 years ago

Any suggestions for the right place to patch

Good question, bp-core-adminbar is responsible for the secondary user account series of links so assuming then that patch needs to address bp-members-adminbar.

#6 @DJPaul
8 years ago

  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to Future Release

#7 @DJPaul
8 years ago

  • Component changed from General - Toolbar/BuddyBar to Toolbar & Notifications

#8 @r-a-y
8 years ago

+1 from me. This has irritated me for a long time now! :)

If you're still interested in patching this up, @sbrajesh, let us know.

#9 @DJPaul
6 years ago

  • Keywords trac-tidy-2018 added

We're closing this ticket because it has not received any contribution or comments for at least two years. We have decided that it is better to close tickets that are good ideas, which have not gotten (or are unlikely to get) contributions, rather than keep things open indefinitely. This will help us share a more realistic roadmap for BuddyPress with you.

Everyone very much appreciates the time and effort that you spent sharing your idea with us. On behalf of the entire BuddyPress team, thank you.

If you feel strongly that this enhancement should still be added to BuddyPress, and you are able to contribute effort towards it, we encourage you to re-open the ticket, or start a discussion about it in our Slack channel. Please consider that time has proven that good ideas without contributions do not get built.

For more information, see https://bpdevel.wordpress.com/2018/01/21/our-awaiting-contributions-milestone-contains/
or find us on Slack, in the #buddypress channel: https://make.wordpress.org/chat/

#10 @DJPaul
6 years ago

  • Milestone Awaiting Contributions deleted
  • Resolution set to maybelater
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.