Skip to:
Content

Opened 3 years ago

Closed 21 months ago

#6683 closed defect (bug) (wontfix)

Activity replies posting as new items

Reported by: style960 Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.3.3
Component: Activity Keywords: has-patch 2nd-opinion
Cc:

Description

User X posts an activity update, user Y replies. The comment from user Y appears nested as a reply to user X, but also appears on the activity stream of user Y as a new activity update. I don't believe replies should be showing as a new update / individual post?

Attachments (1)

6683.patch (2.2 KB) - added by imath 2 years ago.

Download all attachments as: .zip

Change History (10)

#1 @DJPaul
3 years ago

  • Milestone changed from Awaiting Review to 2.4
  • Severity changed from normal to blocker

You're right.

I want to figure out if this is an old bug or a regression, before 2.4. I think we need to set hide_sitewide=1 to fix this.

#2 @DJPaul
3 years ago

  • Keywords needs-patch added
  • Milestone changed from 2.4 to 2.5
  • Severity changed from blocker to normal

Reproducible back to at least 2.0, so let's address this for 2.5.

#3 @henry.wright
3 years ago

I don't believe replies should be showing as a new update / individual post?

It's made clear that it's a comment, rather than an update via the line:

  • Member Y posted a new activity comment n seconds ago

Note the usage of the word "comment" to distinguish this from an "update". If this were an update, it would read:

  • Member Y posted an update n seconds ago

I don't think this is a "bug" but it raises a good question as to whether an activity comment should be individual entry in the stream.

#4 @DJPaul
2 years ago

  • Milestone changed from 2.5 to 2.6

#5 @imath
2 years ago

  • Keywords has-patch added; needs-patch removed

I think the confusion is due to the stream mode as @henry.wright said.

In the just-me scope as it name seems to imply it should fetch the activities generated by the displayed user. So we are using the 'stream' mode to display comments in their own entries.

Problem then is duplicate content when the user comment his own activity or replies to one of the comment made on the activity.

I'm in favor of leaving it the way it is. But if we want to be "strict" we could use the attached patch.

@imath
2 years ago

This ticket was mentioned in Slack in #buddypress by dcavins. View the logs.


2 years ago

#7 @imath
2 years ago

  • Milestone changed from 2.6 to Future Release

I think we need some more time to think about it.

#8 @DJPaul
23 months ago

  • Keywords 2nd-opinion added
  • Milestone changed from Future Release to Under Consideration

I propose we leave this as-is. ?

#9 @DJPaul
21 months ago

  • Milestone Under Consideration deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Leaving as-is per above discussion.

Thanks @style960 for reporting the issue to us, it is appreciated! :)

Note: See TracTickets for help on using tickets.