Skip to:
Content

Opened 3 years ago

Closed 3 years ago

Last modified 18 months ago

#6200 closed defect (bug) (fixed)

BP legacy template RTL style not loading.

Reported by: geminorum Owned by: DJPaul
Milestone: 2.3 Priority: high
Severity: normal Version: 1.9
Component: I18N Keywords:
Cc:

Description

All I see the bp-legacy-css-rtl handle load the previously loaded buddypress.css again.

Seems the BP_Legacy::enqueue_styles() must pass full url location of the buddrpress-rtl.css to wp_style_add_data()

And since the RTL style, unlike default theme behavior, is a duplicate of the main style, I think:

$stylesheet = is_rtl() ? "buddypress-rtl{$min}.css" : "buddypress{$min}.css";
$asset = $this->locate_asset_in_stack( $stylesheet, 'css' );

Change History (4)

#1 @DJPaul
3 years ago

  • Milestone changed from Awaiting Review to 2.3
  • Version changed from 2.2 to 1.9

Need to double-check this but urgh. :(

#2 @DJPaul
3 years ago

  • Owner set to DJPaul
  • Status changed from new to assigned

Confirmed, fixing.

#3 @djpaul
3 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 9629:

BP-Legacy: when loading RTL CSS, don't also load the LTR CSS.

Unlike WordPress, our RTL is a clone of the LTR file, instead of containing just the RTL adjustments.

wp_enqueue_style's RTL support works the WordPress way, not the BuddyPress way, so some of the logic has needed to be duplicated.
We maintain backwards compatibility with the style's existing script names in case existing sites have explicitly de-registered these styles already.

Fixes #6200

#4 @DJPaul
18 months ago

  • Component changed from Locale - RTL to I18N
Note: See TracTickets for help on using tickets.