Skip to:
Content

Opened 3 years ago

Closed 3 years ago

Last modified 19 months ago

#6015 closed defect (bug) (fixed)

grunt build-release fails on SVN checkouts due to bbPress 1

Reported by: slaFFik Owned by: djpaul
Milestone: 2.2 Priority: normal
Severity: normal Version:
Component: Build/Test Tools Keywords: close
Cc:

Description

... on clean BuddyPress trunk install (using WordPress nightly builds too).

Here is how it looks: http://screencast.com/t/1pKzxNR4

Steps to reproduce:

1) new DB, new WordPress install
2) svn checkout for latest BuddyPress
3) activated BuddyPress

Change History (20)

#1 @slaFFik
3 years ago

  • Summary changed from No Activity admin menu icon to No Activity/Groups admin menu icons

Perhaps, the reason is the folder structure in trunk?

#2 @boonebgorges
3 years ago

  • Keywords close added

Yes, I believe this works when run out of the build directory. Run the grunt build script and see.

#3 @slaFFik
3 years ago

Saw lots of errors (jshint), and build dir was not created. Can I ask your assistant in making me familiar with the process you use while working in BuddyPress trunk? I'm in slack, just in case.

Last edited 3 years ago by slaFFik (previous) (diff)

#4 @boonebgorges
3 years ago

Running grunt build should create a build directory, and if files are available in build, then BP will load from them. grunt jshint is not throwing any errors from me.

I generally have an empty build directory and do all development and testing from src. I only build if I need to test something that requires a built resource (like admin scripts when not running SCRIPT_DEBUG).

#5 @slaFFik
3 years ago

Here is what I have: http://screencast.com/t/7gu93MIv
348 errors in 24 files and no build dir.
Also in Users -> Profile Fields css and js files are not loaded in my situation.
Here is what I see on front-end in console: http://screencast.com/t/vtQ7KFCGN

#6 @boonebgorges
3 years ago

Hm, no idea. It's possible your checkout is corrupt somehow. For example, the end of your failing jshint task says that wpAjax is not defined. I assume it's talking about /src/bp-activity/admin/js/admin.js. But there wpAjax is defined as a global on the first line.

Maybe you need to update grunt? npm update

As I can't reproduce, I'm afraid I'm at a loss as for further debugging - you'll have to dig into it yourself. Maybe DJPaul has an idea what's up.

#7 @slaFFik
3 years ago

Latest of everything...
Ok, will no bother you further, will try to find solution somehow.

#8 @boonebgorges
3 years ago

No bother, just not sure what else might be wrong :) Please update this ticket if you figure it out.

#9 @slaFFik
3 years ago

BTW, commented out jshint task in gruntfile and got Done, without errors. (using grunt). But no /build directory.

#10 @slaFFik
3 years ago

That's because I need to run grunt build-release, and not just grunt build. See the task copy:files. This comment in #5160 helped me to understand.

Or grunt copy:files. Now everything works (except jshint errors)

Last edited 3 years ago by slaFFik (previous) (diff)

#11 @DJPaul
3 years ago

I'm glad the reported issue isn't actually a bug, but while the ticket's open, I'm also unable to get grunt to fail on jshint. I tried deleting my node_modules folder then a fresh npm install, and had no problems. slaFFik, can you try deleting node_modules then reinstalling?

I am also wondering if this is something to do with your previous composer install/checkout of BP.

#12 @slaFFik
3 years ago

Deleted node_modules and installed again. Still have that issue.
Composer creates a folder and a file in src, not touching other code, so imo it can't be an issue.

But it seems bbpress is the issue. Are you ignoring it somehow? The output is very big, only portion is available in console, but all issues I see are in bp-forums/bbpress folders.

#13 @DJPaul
3 years ago

  • Component changed from Activity to Core
  • Milestone changed from Awaiting Review to 2.2
  • Summary changed from No Activity/Groups admin menu icons to grunt build-release fails on SVN checkouts due to bbPress 1

Ah hah. Boone and I work from the Git repo, which doesn't have the same externals (bbPress, and kind of BP-Default) that the SVN does. With an SVN checkout, I can recreate the issue. Let me see how to set an ignore path.

#14 @djpaul
3 years ago

In 9146:

Tell Grunt/jshint to ignore src/bp-forums/bbpress/.

This folder is only present on SVN checkouts, but for people trying to contribute to BP using SVN, jshint was failing when it was trying to parse the old bundled version of bbPress.

See #6015

#15 @DJPaul
3 years ago

Still working on other bits of this.

#16 @djpaul
3 years ago

In 9148:

Build: move list of ignored JS files from the Grunt configuration into the .jshintignore file.

The list of ignored JS files in the Grunt configuration was only used by the jshint task, so let's move these into the recently-introduced (r9146) jshint ignore file.

See #6015

#17 @DJPaul
3 years ago

  • Component changed from Core to Build Process

#18 @djpaul
3 years ago

  • Owner set to djpaul
  • Resolution set to fixed
  • Status changed from new to closed

In 9149:

Build: fix Grunt build-release/commit on SVN checkouts.

Old bbPress, which is a SVN external, was not being accounted for in the tasks' working directories/files.
This was causing most of our Grunt build commands to fail when run on a SVN checkout.

Fixes #6015

This ticket was mentioned in Slack in #buddypress by r-a-y. View the logs.


3 years ago

#20 @DJPaul
19 months ago

  • Component changed from Tools - Build Process to Build/Test Tools
Note: See TracTickets for help on using tickets.