Skip to:
Content

BuddyPress.org

Opened 5 years ago

Closed 5 years ago

#5780 closed enhancement (no action required)

bp_edit_profile_button default arguments

Reported by: SGr33n Owned by:
Milestone: Priority: low
Severity: minor Version:
Component: Extended Profile Keywords:
Cc:

Description

Hi,

I'm just working with this function to display the xprofile edit button and I can see that is used nowhere in BuddyPress. Since that I see that the block_self value is true where I suppose it should be false, right? Could be also useful to have the opposite, that would be shown just for the logged in user profile. What you think about this?

Thanks :)

Change History (9)

#1 @SGr33n
5 years ago

  • Component changed from Core to XProfile

#2 @SGr33n
5 years ago

Also bp_button doesn't seem add the id defined in the id argument to the button href.

#3 @DJPaul
5 years ago

bp_edit_profile_button() is old; one of the original xProfile functions. It was last used in BP 1.1.3 in the bp-sn-parent theme. Looking back at the current function and that theme, I think that it looks like the button generated by this function was intended to be used as a shortcut for site admins. Therefore I am a bit concerned about changing the block_self value just in case someone has painstakingly ported an original theme through all the releases since then (admittedly an edge case).

Personally I am split between not doing anything, or as you've just blown the dust off this function, marking it as deprecated. I don't think we would recommend anyone to use it in a modern theme.

Last edited 5 years ago by DJPaul (previous) (diff)

#4 @SGr33n
5 years ago

Thanks DJPaul :) so that's why I found it used nowhere.

#5 @DJPaul
5 years ago

  • Milestone changed from Awaiting Review to 2.2
  • Priority changed from normal to low
  • Severity changed from normal to minor

#6 @SGr33n
5 years ago

  • Type changed from enhancement to defect (bug)

#7 @SGr33n
5 years ago

  • Type changed from defect (bug) to enhancement

#8 @SGr33n
5 years ago

Sorry, wrong ticket modified. Restored 'enhancement'

#9 @DJPaul
5 years ago

  • Milestone 2.2 deleted
  • Resolution set to invalid
  • Status changed from new to closed

Closing as invalid; it works as per my notes in https://buddypress.trac.wordpress.org/ticket/5780#comment:3

Note: See TracTickets for help on using tickets.