Skip to:
Content

BuddyPress.org

Opened 7 years ago

Closed 7 years ago

#5686 closed defect (bug) (duplicate)

Registration page doesn't care of page template

Reported by: SGr33n Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Core Keywords:
Cc:

Description

Hi!

If you set a page template for registration page, it will use the default one.

This doesn't happen for example with activity page, where setting a page template affect the page layout.

Thanks :)

Change History (6)

#1 @r-a-y
7 years ago

  • Keywords reporter-feedback added

If you set a page template for registration page, it will use the default one.

How are you setting a page template for the registration page?

You should use template hierarchy:
http://codex.buddypress.org/themes/theme-compatibility-1-7/template-hierarchy/#registration-page

#2 @SGr33n
7 years ago

Hi Ray!

From the page editor.

#3 @SGr33n
7 years ago

I mean the templates identified by the header comment like this:

<?php
/**
 * Template Name: Full Width Page
 *
 * @package WordPress
 */

#4 @r-a-y
7 years ago

I don't think BuddyPress has ever supported custom page templates:
https://buddypress.trac.wordpress.org/ticket/4328
https://buddypress.trac.wordpress.org/ticket/3741#comment:27

The fact that it's working for you is a little bit of a loophole ;)

I would recommend using template hierarchy. Follow the link I mentioned above.

#5 @SGr33n
7 years ago

You're right, it just was a declaration I put inside functions.php some months ago that gave the template page a certain class.

So the solution you gave here:
https://buddypress.trac.wordpress.org/ticket/4328#comment:5

Wasn't committed?

#6 @r-a-y
7 years ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

The code in ticket:4328#comment:5 wasn't committed.

imath's code in ticket:3741#comment:27 would be more applicable since that uses theme compatibility and not the old, bp-default way of loading templates.

I'm going to close this as a duplicate of #4328.

Note: See TracTickets for help on using tickets.