Skip to:
Content

BuddyPress.org

Opened 8 years ago

Closed 8 years ago

#5591 closed defect (bug) (wontfix)

Extended Profile Tab for User Profile only visible in Network Admin on Multisite Installs

Reported by: janpeters's profile janpeters Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.0
Component: Extended Profile Keywords:
Cc: imath

Description

Hi,

I run a BuddyPress Installation on a Subfolder Network WP Installation.

The new bp-profile-edit Tab for the XProfile fields is only visible in the Network WP-Admin for me. It is completely missing, if I open my Profile page (even in the Network Admin) or try to edit any users Profile starting from a Blogs Dashboard within the Network.

Network Admin -> User -> Edit (Extended Profile exists)
Single Blog -> User -> Edit (No Extended Profile Tab is there)
Profile Link (Admin Bar, upper right) -> Edit Profile (No Extended Profile Tab)

I would expect the tab to always be there?!

Thx and brgds

Jan

Change History (3)

#1 follow-up: @boonebgorges
8 years ago

  • Cc imath added

When BuddyPress is network activated (which I'm assuming it is in your case), we don't show the Extended Profile fields in the single blog wp-admin by design. The original motivation for this is that the rest of BP management happens in Network Admin (Settings, Groups, Activity), so it makes sense to have this here too - it helps to ensure that only the users who *ought* to have access *do* have access.

However, on further consideration, I think that you're right, and the fields should be available everywhere. imath, how hard would it be to show the fields all the time when BP is network activated, limiting permissions based on current_user_can( 'bp_moderate' )?

#2 in reply to: ↑ 1 @imath
8 years ago

Replying to boonebgorges:

imath, how hard would it be to show the fields all the time when BP is network activated, limiting permissions based on current_user_can( 'bp_moderate' )?

It would need some changes in BP_Members_Admin, BP_XProfile_User_Admin... so let's say 2.1, we can work on it and on self profile editing

But i have a conceptual problem actually, as for me the extended profile is in network-admin because it concerns all the members of the network, not the users of each blog. Do we have a profile front page on each blog of the network by default ? Is it possible to create new profile fields from each blog of the network ?

And in a blog, not all the members are there. Most are only in network-admin because not "attached" to a blog. So some super admins would be confused as they would not find all the members and then say.. oh yes i'm in a blog not in network admin..

i'm not sure it's a so great idea, i definitively think it's not a bug but an enhancement.

Finally if you think we should do it, no problem ;)

Last edited 8 years ago by imath (previous) (diff)

#3 @boonebgorges
8 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

And in a blog, not all the members are there. Most are only in network-admin because not "attached" to a blog.

Yeah, you're right. Frankly, this whole situation is a mess. The relevant conception of what counts as a "member" from the point of view of BuddyPress is totally different from what counts as a "member" from the point of view of WP Multisite. In theory (and this is just me thinking aloud, not necessarily a concrete suggestion), the root blog Dashboad > Users should show *all* BuddyPress members, not just those with a role on the current blog (or maybe there could be a separate tab to show all members). I agree with imath that this problem should be solved before we attempt to do anything like what's suggested here.

I'm going to mark this ticket as wontfix for the reasons discussed above. If we decide to overhaul the way that the root-blog Users panel works at some point in the future, we can reconsider.

(Note - self-editing is, I think, a separate issue, and not dependent on the discussion here.)

Note: See TracTickets for help on using tickets.