Skip to:
Content

BuddyPress.org

Opened 6 years ago

Closed 6 years ago

#5551 closed defect (bug) (fixed)

BuddyPress 2.0 Theme Switching Error Message

Reported by: DennisBarkerCV Owned by: imath
Milestone: 2.0.1 Priority: normal
Severity: normal Version: 2.0
Component: Members Keywords: has-patch commit
Cc:

Description

I got an error message when switching themes having just updated to BuddyPress 2.0 possibly a typo but the theme wouldn't switch.

Attachments (2)

Snap 2014-04-16 at 20.14.39.png (43.6 KB) - added by DennisBarkerCV 6 years ago.
Screenshot of error message
5551.patch (390 bytes) - added by imath 6 years ago.

Download all attachments as: .zip

Change History (11)

@DennisBarkerCV
6 years ago

Screenshot of error message

#1 @boonebgorges
6 years ago

  • Keywords reporter-feedback added
  • Version set to 2.0

DennisBarkerCV - Can you share some more information about your issue?

  • What version of WP are you running?
  • If you recall, which themes are you switching to/from?
  • Who is your host? I don't recognize this fatal error screen.
  • Can you please specify the exact steps you went through to switch themes? Ie, did it happen through the Theme Customizer, Theme Preview, etc?

#2 @DennisBarkerCV
6 years ago

I'm running WordPress 3.9 which has just happened today.host is webenabled.I don't recall exactly which theme,but i was in the main theme listing and activated from there.I've since deactivated BuddyPress just in case:)

I'll try a few themes later and let you know if I track anything specific down.

#3 @DennisBarkerCV
6 years ago

Just reactivated BuddyPress2.0 and switched themes a few times but could not reproduce the error message.Everything seems to be working fine now for me.

#4 @imath
6 years ago

This is weird because line 825 should only be run if a user query is done.

#5 @DennisBarkerCV
6 years ago

The error has been reported in the support forum along with a possible solution.
http://buddypress.org/support/topic/fatal-error-call-to-undefined-function-get_current_screen/

#6 @imath
6 years ago

  • Component changed from Core to Members
  • Keywords has-patch 2nd-opinion added; reporter-feedback removed
  • Milestone changed from Awaiting Review to 2.0.1

I'd really like to understand why this is happening. It's like something is making a user query before the admin screen is set ??

I think the 5551.patch can prevent this from happening.

@imath
6 years ago

#7 @boonebgorges
6 years ago

  • Keywords commit added; 2nd-opinion removed

Hm, no idea why this would be happening either. Could be caused by a number of different kinds of plugins. 5551.patch looks like a fine fix for me.

#8 @imath
6 years ago

In 8303:

Check get_current_screen() is available before using it

In non multisite configs, to avoid displaying the signups (user_status set to 2) into the users administration screen, a filter to the user query is applyed after checking the current screen is the users one. It appears to be problematic on some configs. So we need to check the function get_current_screen() exists just before using it.

see #5551

#9 @imath
6 years ago

  • Owner set to imath
  • Resolution set to fixed
  • Status changed from new to closed

In 8304:

Check get_current_screen() is available before using it

In non multisite configs, to avoid displaying the signups (user_status set to 2) into the users administration screen, a filter to the user query is applyed after checking the current screen is the users one. It appears to be problematic on some configs. So we need to check the function get_current_screen() exists just before using it.

Fixes #5551

Note: See TracTickets for help on using tickets.