Skip to:
Content

Opened 11 months ago

Closed 11 months ago

Last modified 11 months ago

#5507 closed defect (bug) (fixed)

comments: activity to post sync

Reported by: shanebp Owned by:
Milestone: 2.0 Priority: normal
Severity: normal Version: 2.0
Component: Component - Blogs Keywords:
Cc: shane@…

Description

Tested with BP 2.0 beta and WP 3.8.1 with no other plugins and in both 2012 and 2013 themes.

If 'Bob' publishes a post and :

  1. adds a comment in the Activity stream, it will appear in the post comments
  2. adds a comment in the post, it will appear in the activity stream

If 'Sue' re Bob's post:

  1. adds a comment in the Activity stream, it will appear in the post comments
  2. adds a comment in the post, it will NOT appear in the activity stream

It does not matter what roles Bob and Sue have.
This issue appears when 'Activity auto-refresh' is on OR off.

So it seems that comments added to a post only appear in the activity stream if the comment was added by the post creator.

Perhaps this is expected behaviour, but it seems inconsistent and is confusing.

Change History (4)

comment:1 @r-a-y11 months ago

  • Component changed from Activity to Blogs
  • Milestone set to 2.0

Confirmed.

If Sue adds a comment to a post and the post moderates comments before being approved, then the corresponding activity comment is not created when the post comment is approved.

Will look into it.

Last edited 11 months ago by r-a-y (previous) (diff)

comment:2 @r-a-y11 months ago

In 8228:

Blogs: When recording a comment and looking for the blog post activity item, do not add a check for the user ID.

Adding a check for the user ID is not needed and would be inaccurate
since a commenter's user ID will not be the same as the post author's.
When the user IDs do not match, the associated activity comment is not
created.

See #5130, #5507

comment:3 @r-a-y11 months ago

  • Resolution set to fixed
  • Status changed from new to closed

shanebp - There was a bug in looking up the blog post activity item, which prevented comments that were not from the blog post author to not be recorded as an activity comment.

Let me know if this fixes the problem.

comment:4 @shanebp11 months ago

Fix confirmed - thanks r-a-y

Note: See TracTickets for help on using tickets.