Skip to:
Content

BuddyPress.org

Opened 6 years ago

Closed 6 years ago

#5453 closed defect (bug) (fixed)

xprofile Administration - js do not reset options when [x] clicked

Reported by: imath Owned by: imath
Milestone: 2.0 Priority: normal
Severity: normal Version: 1.5
Component: Extended Profile Keywords: has-patch commit
Cc:

Description

Hi,

While testing #5220, i've found that when creating/editing a field with options to set (radio / checkbox / selectbox..). If you add some text in the option field, then click on [x] link, the field is hidden, but the value is not removed. As a result when saving / updating the field, the "removed" option is saved.

I think it's a js issue due to the fact the id of the field is different thant the id of the container div. I suggest the attached diff to solve it.

Attachments (1)

5453.diff (10.5 KB) - added by imath 6 years ago.

Download all attachments as: .zip

Change History (4)

@imath
6 years ago

#1 @DJPaul
6 years ago

  • Version changed from 1.9.2 to 1.5

Good find. I've confirmed this exist all the way back to 1.5 (it wasn't easy to go much further back).

#2 @r-a-y
6 years ago

  • Keywords commit added

Looks good!

#3 @imath
6 years ago

  • Owner set to imath
  • Resolution set to fixed
  • Status changed from new to closed

In 8180:

In Profile fields management screens, make sure the cancelled field options are not saved

When editing fields using options such as select boxes, radio boxes, check boxes, etc. when an admin cancelled one or more options, they were still saved. This make sure cancelled options are fully removed before the profile field is edited.

Fixes #5453

Note: See TracTickets for help on using tickets.