Skip to:
Content

Opened 6 months ago

Closed 6 months ago

Last modified 6 months ago

#5219 closed defect (bug) (fixed)

Login from Sidebar Widget only works on second try if cookies were cleared.

Reported by: andreas.triller Owned by: r-a-y
Milestone: 1.9 Priority: normal
Severity: normal Version: 1.8.1
Component: Theme Keywords:
Cc:

Description

Maybe I am missing something, but the sidebar widget login included in bp-default theme does not set the test cookie which is accessed by wp-login.php. A fresh browser with no cookies gets an error saying "your browser does not accept cookies" and is redirected to wp-login.php which successfully sets the test cookie. A subsequent login (also through the sidebar widget) works.

I found a solution (5 years old) in this thread (post by jeffbaier):
http://wordpress.org/support/topic/wordpress-requires-cookies-username-field-empty-password-field-empty-on

Would be nice to include this in header.php in the next release.

Change History (3)

comment:1 r-a-y6 months ago

This is caused by a recent change in WordPress. See #WP24961.

I haven't seen a reported issue on WordPress yet. So I'm going to do a bit more testing before I mark this as invalid.

comment:2 r-a-y6 months ago

  • Owner set to r-a-y
  • Resolution set to fixed
  • Status changed from new to closed

In 7485:

Remove 'testcookie' hidden field in BP's login forms.

Due to a recent change in WordPress (http://core.trac.wordpress.org/changeset/25045)
that checks the 'testcookie' value as well as a real cookie value, this
broke login attempts from BP's login forms.

This commit removes the 'testcookie' hidden field so BuddyPress can bypass
the cookie check and allows login attempts to work as before.

Fixes #5219.

comment:3 r-a-y6 months ago

  • Keywords 2nd-opinion removed
  • Milestone changed from Awaiting Review to 1.9
Note: See TracTickets for help on using tickets.