Skip to:
Content

BuddyPress.org

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#5124 closed defect (bug) (fixed)

include_once(feeds/bp-activity-mentions-feed.php) fails

Reported by: handbike Owned by: r-a-y
Milestone: 1.8.1 Priority: normal
Severity: normal Version: 1.8
Component: Activity Keywords: has-patch dev-feedback commit
Cc:

Description

Since buddypress 1.8 we have lots of errors in our logfile:

include_once(feeds/bp-activity-mentions-feed.php) [<a href='function.include-once'>function.include-once</a>]: failed to open stream: No such file or directory in /xxx/wp-content/plugins/buddypress/bp-activity/bp-activity-actions.php on line 576

And yes, the file does not exist, the feed folder is empty.

Attachments (1)

5124.01.patch (1.5 KB) - added by r-a-y 7 years ago.

Download all attachments as: .zip

Change History (7)

#1 @boonebgorges
7 years ago

  • Milestone changed from Awaiting Review to 1.8.1
  • Owner set to r-a-y
  • Status changed from new to assigned

Confirmed. r-a-y, could you have a look? Looks like this is a spot we missed with the new feed class.

#2 @r-a-y
7 years ago

Goddammit, I suck!

Patch coming in a bit.

@r-a-y
7 years ago

#3 @r-a-y
7 years ago

  • Keywords has-patch dev-feedback added

Looks like I don't suck that much! It was in my initial patch - attachment:5020.02.patch:ticket:5020.

However, for this ticket, 01.patch introduces two strings. Since we hate to introduce new strings into point releases, could use some dev feedback.

#4 @boonebgorges
7 years ago

  • Keywords commit added

I guess I'm the one who sucks!

Since we hate to introduce new strings into point releases, could use some dev feedback.

Well, right now, the feed's not working at all. So, while it's crummy to add strings that'll be untranslated in a point release, at least the feed will be working.

#5 @boonebgorges
7 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 7335:

Implement BP_Activity_Feed for activity mentions feed

This particular feed was missed during the original implementation of
BP_Activity_Feed. See #5020, r7207. As a result, the mentions feed was
attempting to load from a separate feed template file that no longer
exists. This broke the feed and filled the error logs with warnings.

Fixes #5124

Props r-a-y

#6 @boonebgorges
7 years ago

In 7336:

Implement BP_Activity_Feed for activity mentions feed

This particular feed was missed during the original implementation of
BP_Activity_Feed. See #5020, r7207. As a result, the mentions feed was
attempting to load from a separate feed template file that no longer
exists. This broke the feed and filled the error logs with warnings.

Fixes #5124

Props r-a-y

Note: See TracTickets for help on using tickets.