Skip to:
Content

BuddyPress.org

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#4921 closed defect (bug) (no action required)

Access level to BP_Legacy::setup_globals() must be protected (as in class BP_Theme_Compat) or weaker

Reported by: modemlooper Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.7
Component: Core Keywords: reporter-feedback
Cc:

Description

Getting this error when using theme switcher plugins with latest RC. Did not happen before.

Change History (4)

#1 @modemlooper
9 years ago

It's buddypress-functions.php. When included in a custom theme it throws up that error.

Last edited 9 years ago by modemlooper (previous) (diff)

#2 follow-up: @boonebgorges
9 years ago

  • Keywords reporter-feedback close added

When included in a custom theme it throws up that error.

I assume that by "included" you mean that you have taken a copy of the buddypress-functions.php file and put it into your child theme. If so, the problem is likely that the version you copied over is out of date. Please replace it with the latest version from bp-legacy.

#3 in reply to: ↑ 2 @johnjamesjacoby
9 years ago

  • Keywords close removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Replying to boonebgorges:

I assume that by "included" you mean that you have taken a copy of the buddypress-functions.php file and put it into your child theme. If so, the problem is likely that the version you copied over is out of date. Please replace it with the latest version from bp-legacy.

Confirmed. It's correct in buddypress-functions.php, so no changes needed. Closing as invalid.

#4 @modemlooper
9 years ago

Ahh! dunce!

Note: See TracTickets for help on using tickets.