Skip to:
Content

BuddyPress.org

Opened 7 years ago

Closed 4 years ago

#4852 closed defect (bug) (fixed)

Site Directory Missing Sites

Reported by: ubernaut Owned by: imath
Milestone: 2.3 Priority: low
Severity: trivial Version:
Component: Blogs Keywords: has-patch
Cc:

Description

if you create a site in network admin and do not define the title the site is not added to the directory at least under 1.6.x

Attachments (1)

4852.01.patch (451 bytes) - added by wolfhoundjesse 5 years ago.

Download all attachments as: .zip

Change History (6)

#1 @boonebgorges
7 years ago

  • Component changed from Core to Blogs
  • Milestone changed from Awaiting Review to Future Release
  • Priority changed from normal to low
  • Severity changed from normal to trivial

This appears to be by design: https://buddypress.trac.wordpress.org/browser/trunk/bp-blogs/bp-blogs-functions.php?annotate=blame#L141 (see 153-154)

What exactly would we show in the directory if a site doesn't have a name? The URL? (That's what WP does, eg, in the toolbar.) I guess I don't see a problem with this; we'll just need a patch that tells bp_blogs_record_blog() to use the URL when no $name is passed.

#2 @ubernaut
7 years ago

makes sense to me

#3 @r-a-y
5 years ago

  • Keywords needs-patch good-first-bug added

#4 @DJPaul
4 years ago

  • Keywords has-patch added; needs-patch good-first-bug removed
  • Milestone changed from Future Release to 2.3

Oops, we've missed that this ticket had a patch attached to it for quite a long time. It still looks valid.

I don't have a MS dev install at the moment, so moving to 2.3 for someone to set one up and test the issue and the fix.

#5 @imath
4 years ago

  • Owner set to imath
  • Resolution set to fixed
  • Status changed from new to closed

In 9632:

Blogs component: use the site url if the blog name is not set when registering a blog

So far when the blog name was not set, bp_blogs_record_blog() was not recording the blog. We will now use the blog url as a fallback but make sure the blog is recorded.

Props wolfhoundjesse

Fixes #4852

Note: See TracTickets for help on using tickets.