Skip to:
Content

BuddyPress.org

Opened 11 years ago

Closed 11 years ago

Last modified 8 years ago

#4790 closed defect (bug) (fixed)

Avatars, recipients and date box not wrapping properly on the messages page

Reported by: magichew's profile magichew Owned by:
Milestone: 1.7 Priority: low
Severity: minor Version: 1.7
Component: Templates Keywords:
Cc:

Description

The avatar pictures appears to be underneath the recipient and date text in messages page.

I've included a photograph to demonstrate.

Attachments (3)

Messages Issue.jpg (31.0 KB) - added by magichew 11 years ago.
Screen grab of messages issue
4790.patch (520 bytes) - added by boonebgorges 11 years ago.
BP Messages.jpg (13.7 KB) - added by magichew 11 years ago.

Download all attachments as: .zip

Change History (16)

@magichew
11 years ago

Screen grab of messages issue

#1 @boonebgorges
11 years ago

  • Component changed from Core to Theme
  • Keywords reporter-feedback added
  • Priority changed from normal to low
  • Severity changed from normal to minor

What theme are you using? WP/BP versions?

#2 @magichew
11 years ago

  • Keywords reporter-feedback removed

Sorry for the delay in getting back to you.

I'm using the Twenty Twelve Theme, the latest trunk version of BP and the 3.5.2 alpha WP.

#3 @boonebgorges
11 years ago

  • Keywords reporter-feedback added

By the looks of that screengrab, there's some customization going on. The yellow box around the timestamp is no longer in BP trunk. Are you sure that you don't have a custom template somewhere? Check that your theme doesn't contain members/single/messages/ or anything like that.

#4 @magichew
11 years ago

  • Keywords reporter-feedback removed

It's all vanilla. That screenshot was taken a while ago with the latest version at that time. It still persists now with that latest version. Do you need a new screenshot?

#5 @boonebgorges
11 years ago

I guess you can attach a new screenshot, but in any case I can't reproduce the issue on my local installations. Do you know enough about your browser's dev tools to debug the CSS?

#6 @magichew
11 years ago

Just looked now and it's all good in Firefox but still problems in Safari .

#7 @boonebgorges
11 years ago

  • Milestone changed from Awaiting Review to 1.7

Thanks for the additional details. I still can't totally reproduce the screenshots as you've described them, but I do see that Twenty Twelve is inserting some responsive CSS that's causing problems in the context of this table. Could you test 4790.patch to see if it fixes your problem too?

@boonebgorges
11 years ago

#8 @magichew
11 years ago

Bingo. Fixed in safari. And hasn't effected anything in Firefox.

#9 @magichew
11 years ago

Just had a thought, the messages screen could do with a little bit of adjustment.

The check box and the delete button shouldn't be together. For my money it makes more sense to have the check box as the left most element and the delete button all the way to the right like the image I've attached.

@magichew
11 years ago

#10 @boonebgorges
11 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [6839]) Improved avatar appearance on Messages lists when using theme compat

Some WP themes accomplish responsiveness for images by using a max-width: 100%;
attribute for all images in the content area. (Twenty Twelve is an example.)
This declaration causes problems for the way that the Messages screen markup
is built, so that the container element for the avatar has no width, and thus
the avatar doesn't show up on Webkit browsers.

Fixes #4790

#11 @boonebgorges
11 years ago

magichew - Your suggestion about moving the checkbox is sensible, but the behavior you describe is not a regression for 1.7, so it's too late to fix it for this cycle. Please open a separate enhancement ticket with the request.

#12 @magichew
11 years ago

No probs Boone. Thanks for your help with this.

#13 @DJPaul
8 years ago

  • Component changed from Appearance - Template Parts to Templates
Note: See TracTickets for help on using tickets.